My Answer to GPS Tracking

After many problems with tracking and mapping the people in my house (Wife and 2 kids and me), I finally was able to put together a system that is working for me. Its overly complex, but I have now come to love node-red.

I tried owntracks to mosquitto add-on - had issues with SSL, and Duckdns redirecting consistantly

I tried icloud component - amazing but massive battery drain

I signed up for free Cloud MQTT account and run my owntracks clients through there and connect to node-red running on my HA box update my entities via device_tracker.see service.

Node-red is quite amazing and I am even running the worldmap node to create an alternative map tab that I have show up in my homeassistant bar.

1 Like

Hi, I am just starting with Node-RED. I have got the CloudMQTT node working but can you please give me a pointer on how to set up the device_tracker.see service.


I am even running the worldmap node to create an alternative map tab that I have show up in my homeassistant bar

Do you mean that you just have a link to the map page in the left hand column? Or did you actually get it to add the map as a camera (or other entity)?

I used an iframe in my config.yaml to point to the openmap url. But you could do the same thing as a generic camera i assume.

@Mkotlarz Can you please share your node-red tracking setup? thanks.

unfortunately, my neighbors house was hit by lightning and it fried my HA setup (through the ethernet port no less). So i have lost all my custom stuff. I have only recently (yesterday) gotten the wherewithal to rebuild my nuc with hassio. so I have nothing to share anymore…

When I get back to Node-red I will do it if I go that route.

I have been trying to use Google Location Sharing, but the damn cookie issues are just as bad. I wish there was some easy way for this.


1 Like

Sorry for the no response but as my answer belowe states my HA endeavors have been a bit “Challenged”

So go to the services tab in HA, this works the same in node-red but I don’t have it installed yet.

Go to HA services tab
select device.tracker.see
input new information to write in JSON
“dev_id”: “mike”,
“gps”: “51.509802, -0.086692”

add any additional fields you want to edit (look below on the services screen to see the choices) then call service.

Its literally the same approach in just using the HA call service node.


1 Like

oh dear sorry to hear about that hopefully everything should be up and running for you soon buddy.

quick question on your nuc? what OS do you use on your NUC and how do you install HA on it?


Ubuntu Server, and I run HASSIO in a docker container. Ubuntu server 16.04

This way I get all those awesome HASSIO add ons and I can add whatever I want to the server itself


1 Like