My (outdated) Quick Start for Home Assistant Core on FreeNAS 11.2

@troy,

I did. I created a token for each one and applied it as document says. Restarted the jail also. Any ideas?

Thanks

@Dario_Lemes_Gonzalez,

Sorry for the delay, (travel, work, trade show, crazy)

So I guess we need to narrow down where to look. Let’s try this first to determine who the culprit is.
Let’s first just turn appdaemon and the configurator off to be sure the error goes away, Then we’ll re-enable each, one at a time to figure out who is misbehaving.

Starting from your FreeNAS console we log into the jail and stop appdaemon and configurator, then restart HA

iocage console homeassistant
service appdaemon stop
service configurator stop
service homeassistant restart

At this point the error should be gone for sure. Please confirm before moving on.
Next we can re-enable appdaemon

service appdaemon start
service homeassistant restart   ## I don't know if you really need to restart HA again

Check HA logs for login error, then re-enable the configurator

service configurator restart
service homeassistant restart   ## I don't know if you really need to restart HA again

Check HA logs again for login error.
When we know who the culprit is we can move on to check the related config file.

Hey Troy.

I’m relatively new to FreeNas 11.2, I have it running plex but I have not dove any deeper than that since I set it up. I am trying to get Home Assistant installed and I have been following your guide to install using the script.

I can install ok but I can’t connect to the url.

The URL I get is

Home Assistant: http://192.168.0.40:8123

It just tells me the site can’t be reached. I can however reach HA Dashboard and Configurator.

Here are the logs from the homeassistant_daemon. It appears to fail on a lot of dependencies. Any help would be appreciated.

2019-11-04 23:17:52 INFO (SyncWorker_0) [homeassistant.config] Upgrading configuration directory from 0.7.7 to 0.101.2
2019-11-04 23:17:52 INFO (SyncWorker_0) [homeassistant.config] Migrating google tts to google_translate tts
2019-11-04 23:17:53 INFO (SyncWorker_2) [homeassistant.util.package] Attempting install of pyotp==2.3.0
2019-11-04 23:17:54 INFO (SyncWorker_3) [homeassistant.util.package] Attempting install of PyQRCode==1.2.1
2019-11-04 23:17:56 INFO (SyncWorker_14) [homeassistant.loader] Loaded group from homeassistant.components.group
2019-11-04 23:17:56 INFO (SyncWorker_13) [homeassistant.loader] Loaded updater from homeassistant.components.updater
2019-11-04 23:17:56 INFO (SyncWorker_10) [homeassistant.loader] Loaded automation from homeassistant.components.automation
2019-11-04 23:17:56 INFO (SyncWorker_9) [homeassistant.loader] Loaded http from homeassistant.components.http
2019-11-04 23:17:56 INFO (SyncWorker_18) [homeassistant.loader] Loaded persistent_notification from homeassistant.components.persistent_notification
2019-11-04 23:17:56 INFO (SyncWorker_15) [homeassistant.loader] Loaded default_config from homeassistant.components.default_config
2019-11-04 23:17:56 INFO (SyncWorker_12) [homeassistant.loader] Loaded tts from homeassistant.components.tts
2019-11-04 23:17:56 INFO (SyncWorker_7) [homeassistant.loader] Loaded panel_iframe from homeassistant.components.panel_iframe
2019-11-04 23:17:56 INFO (SyncWorker_16) [homeassistant.loader] Loaded script from homeassistant.components.script
2019-11-04 23:17:56 INFO (SyncWorker_17) [homeassistant.loader] Loaded homeassistant from homeassistant.components.homeassistant
2019-11-04 23:17:56 INFO (SyncWorker_8) [homeassistant.loader] Loaded sensor from homeassistant.components.sensor
2019-11-04 23:17:56 INFO (SyncWorker_19) [homeassistant.loader] Loaded device_automation from homeassistant.components.device_automation
2019-11-04 23:17:56 INFO (MainThread) [homeassistant.setup] Setting up persistent_notification
2019-11-04 23:17:56 INFO (MainThread) [homeassistant.setup] Setup of domain persistent_notification took 0.0 seconds.
2019-11-04 23:17:56 INFO (SyncWorker_11) [homeassistant.loader] Loaded frontend from homeassistant.components.frontend
2019-11-04 23:17:56 INFO (MainThread) [homeassistant.setup] Setting up homeassistant
2019-11-04 23:17:56 INFO (MainThread) [homeassistant.setup] Setup of domain homeassistant took 0.0 seconds.
2019-11-04 23:17:56 INFO (SyncWorker_10) [homeassistant.loader] Loaded webhook from homeassistant.components.webhook
2019-11-04 23:17:56 INFO (SyncWorker_5) [homeassistant.loader] Loaded api from homeassistant.components.api
2019-11-04 23:17:56 INFO (SyncWorker_9) [homeassistant.loader] Loaded cloud from homeassistant.components.cloud
2019-11-04 23:17:56 INFO (SyncWorker_1) [homeassistant.loader] Loaded auth from homeassistant.components.auth
2019-11-04 23:17:56 INFO (SyncWorker_3) [homeassistant.loader] Loaded config from homeassistant.components.config
2019-11-04 23:17:56 INFO (SyncWorker_9) [homeassistant.loader] Loaded lovelace from homeassistant.components.lovelace
2019-11-04 23:17:56 INFO (SyncWorker_2) [homeassistant.loader] Loaded onboarding from homeassistant.components.onboarding
2019-11-04 23:17:56 INFO (SyncWorker_14) [homeassistant.loader] Loaded system_log from homeassistant.components.system_log
2019-11-04 23:17:56 INFO (SyncWorker_15) [homeassistant.loader] Loaded websocket_api from homeassistant.components.websocket_api
2019-11-04 23:17:56 INFO (SyncWorker_6) [homeassistant.loader] Loaded history from homeassistant.components.history
2019-11-04 23:17:56 INFO (SyncWorker_0) [homeassistant.loader] Loaded recorder from homeassistant.components.recorder
2019-11-04 23:17:56 INFO (SyncWorker_18) [homeassistant.loader] Loaded logbook from homeassistant.components.logbook
2019-11-04 23:17:56 INFO (SyncWorker_12) [homeassistant.loader] Loaded map from homeassistant.components.map
2019-11-04 23:17:56 INFO (SyncWorker_7) [homeassistant.loader] Loaded mobile_app from homeassistant.components.mobile_app
2019-11-04 23:17:56 INFO (SyncWorker_16) [homeassistant.loader] Loaded person from homeassistant.components.person
2019-11-04 23:17:56 INFO (SyncWorker_17) [homeassistant.loader] Loaded ssdp from homeassistant.components.ssdp
2019-11-04 23:17:56 INFO (SyncWorker_8) [homeassistant.loader] Loaded sun from homeassistant.components.sun
2019-11-04 23:17:56 INFO (SyncWorker_13) [homeassistant.loader] Loaded system_health from homeassistant.components.system_health
2019-11-04 23:17:56 INFO (SyncWorker_19) [homeassistant.loader] Loaded zeroconf from homeassistant.components.zeroconf
2019-11-04 23:17:56 INFO (MainThread) [homeassistant.bootstrap] Setting up {'system_log'}
2019-11-04 23:17:56 INFO (SyncWorker_11) [homeassistant.util.package] Attempting install of aiohttp_cors==0.7.0
2019-11-04 23:17:58 ERROR (MainThread) [homeassistant.config] Invalid config for [http]: [api_password] is an invalid option for [http]. Check: http->http->api_password. (See /home/hass/homeassistant/configuration.yaml, line 24). Please check the docs at https://home-assistant.io/integrations/http/
2019-11-04 23:17:58 ERROR (MainThread) [homeassistant.setup] Setup failed for http: Invalid config.
2019-11-04 23:17:58 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of system_log. Setup failed for dependencies: http
2019-11-04 23:17:58 ERROR (MainThread) [homeassistant.setup] Setup failed for system_log: Could not set up all dependencies.
2019-11-04 23:17:58 INFO (SyncWorker_9) [homeassistant.util.package] Attempting install of sqlalchemy==1.3.10
2019-11-04 23:18:02 INFO (MainThread) [homeassistant.setup] Setting up recorder
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setup of domain recorder took 0.4 seconds.
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setting up sun
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setup of domain sun took 0.0 seconds.
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setting up lovelace
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Error during setup of component lovelace
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/setup.py", line 172, in _async_setup_component
    hass, processed_config
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/lovelace/__init__.py", line 66, in async_setup
    hass.components.frontend.async_register_built_in_panel(
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/loader.py", line 421, in __getattr__
    component: Optional[ModuleType] = integration.get_component()
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/loader.py", line 223, in get_component
    cache[self.domain] = importlib.import_module(self.pkg_path)
  File "/srv/homeassistant/lib/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 678, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/frontend/__init__.py", line 10, in <module>
    import hass_frontend
ModuleNotFoundError: No module named 'hass_frontend'
2019-11-04 23:18:03 INFO (SyncWorker_2) [homeassistant.util.package] Attempting install of netdisco==2.6.0
2019-11-04 23:18:03 INFO (SyncWorker_14) [homeassistant.loader] Loaded yr from homeassistant.components.yr
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setting up person
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setting up group
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setup of domain group took 0.0 seconds.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of auth. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for auth: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of history. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for history: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of webhook. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for webhook: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of system_health. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for system_health: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of websocket_api. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for websocket_api: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of api. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for api: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of config. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for config: Could not set up all dependencies.
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setting up script
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setup of domain script took 0.0 seconds.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of tts. Setup failed for dependencies: http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for tts: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for introduction: Integration not found.
2019-11-04 23:18:03 INFO (MainThread) [homeassistant.setup] Setup of domain person took 0.0 seconds.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of onboarding. Setup failed for dependencies: auth, http
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for onboarding: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of device_automation. Setup failed for dependencies: webhook
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for device_automation: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of cloud. Setup failed for dependencies: http, webhook
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of zeroconf. Setup failed for dependencies: api
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for zeroconf: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of frontend. Setup failed for dependencies: api, auth, http, lovelace, onboarding, system_log, websocket_api
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for frontend: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of automation. Setup failed for dependencies: device_automation, webhook
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for automation: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of mobile_app. Setup failed for dependencies: cloud, http, webhook
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for mobile_app: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of map. Setup failed for dependencies: frontend
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for map: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of panel_iframe. Setup failed for dependencies: frontend
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for panel_iframe: Could not set up all dependencies.
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of logbook. Setup failed for dependencies: frontend
2019-11-04 23:18:03 ERROR (MainThread) [homeassistant.setup] Setup failed for logbook: Could not set up all dependencies.
2019-11-04 23:18:05 INFO (MainThread) [homeassistant.setup] Setting up ssdp
2019-11-04 23:18:05 INFO (MainThread) [homeassistant.setup] Setup of domain ssdp took 0.0 seconds.
2019-11-04 23:18:05 INFO (SyncWorker_18) [homeassistant.util.package] Attempting install of distro==1.4.0
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.setup] Setting up updater
2019-11-04 23:18:06 INFO (SyncWorker_16) [homeassistant.util.package] Attempting install of xmltodict==0.12.0
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.setup] Setup of domain updater took 0.0 seconds.
2019-11-04 23:18:06 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of default_config. Setup failed for dependencies: automation, cloud, config, frontend, history, logbook, map, mobile_app, system_health, zeroconf
2019-11-04 23:18:06 ERROR (MainThread) [homeassistant.setup] Setup failed for default_config: Could not set up all dependencies.
2019-11-04 23:18:06 INFO (SyncWorker_7) [homeassistant.loader] Loaded binary_sensor from homeassistant.components.binary_sensor
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.setup] Setting up binary_sensor
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.setup] Setup of domain binary_sensor took 0.0 seconds.
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up binary_sensor.updater
2019-11-04 23:18:06 INFO (MainThread) [homeassistant.helpers.entity_registry] Registered new binary_sensor.updater entity: binary_sensor.updater
2019-11-04 23:18:08 INFO (MainThread) [homeassistant.setup] Setting up sensor
2019-11-04 23:18:08 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.yr
2019-11-04 23:18:08 INFO (MainThread) [homeassistant.setup] Setup of domain sensor took 0.3 seconds.
2019-11-04 23:18:11 INFO (MainThread) [homeassistant.bootstrap] Home Assistant initialized in 18.79s
2019-11-04 23:18:11 WARNING (MainThread) [homeassistant.bootstrap] Python 3.6 support is deprecated and will be removed in the first release after December 15, 2019. Please upgrade Python to 3.7.0 or higher.
2019-11-04 23:18:11 INFO (MainThread) [homeassistant.core] Starting Home Assistant
2019-11-04 23:18:11 INFO (MainThread) [homeassistant.core] Timer:starting

@skearney First welcome to the forums

Sorry this isn’t working for you. There has been a breaking change to my example configuration file.

Unfortunately, support for the API password has been removed from HA beginning with 0.101 and now the configuration will no longer pass validation.

To get HA running:

If your still having trouble we may need to downgrade to HA 0.100.3 just to get the UI configured. I have had trouble getting HA to start with a clean install after version 0.101 (but I’ve not had time to investigate the issue because of travel for work)

The workaround for now seems to be a downgrade to HA 0.100.3 just long enough to go through initial configuration. Once the HA GUI is up and running we can upgrade again to the latest HA and everything will continue to work.

Sorry for the inconvenience, it will likely be a week or two before I can have time to fix this properly. If you still can not get to the GUI after commenting out the configuration lines as shown above, You can find the steps to downgrade HA HERE

Another question that I cant find the answer too:

I am trying to update to python 3.7 since that is a future requirment, but I get this error when following the above guide:

[[email protected] /]# pkg install -y python37 py37-sqlite3 ca_root_nss python3.7 -m ensurepip
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: No packages available to install matching 'python3.7' have been found in the repositories

Any ideas on how to solve it?

1 Like

Upgrading Home Assistant to use python 3.7

We can’t just upgrade the existing virtualenv. We’ll have to create a new one using python 3.7 and re-install Home Assistant.

First log into the HA jail and stop Home Assistant

iocage console homeassistant
service homeassistant stop

Next we’ll rename the existing virtualenv in case there is any need to restore it later.

mv /srv/homeassistant /srv/homeassistant.old

If you want to just remove the existing virtualenv you can do this instead

rm -rf /srv/homeassistant

With the old virtualenv either renamed or deleted we can proceed to install python 3.7 and create a new virtualenv.

pkg install -y python37 py37-sqlite3
python3.7 -m ensurepip
pip3 install --upgrade pip
pip3 install --upgrade virtualenv
install -d -g hass -o hass -m 775 -- /srv/homeassistant

Now we can switch to user hass , activate the virtualenv and re-install Home-Assistant

su - hass
   virtualenv -p /usr/local/bin/python3.7 /srv/homeassistant
   source /srv/homeassistant/bin/activate
   pip3 install --upgrade homeassistant

There seems to be some bug causing the front-end to not get installed properly.
For now we can get around this by installing it manually.

   pip3 install --upgrade home-assistant-frontend
   deactivate && exit

Finally restart homeassistant

service homeassistant start

Profit!

5 Likes

you are the man!

Thank you very much.

Quick question: will the bash update work after we do this for future updates ?

Thanks again.

Yep! At least it should, if not I’ll fix it so it does :wink:

@troy

I’m trying to use homekit controller component and i’m getting OPENSSL issue with freebsd.

2019-11-11 12:13:47 ERROR (MainThread) [homeassistant.components.homekit_controller.config_flow] Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
 File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 251, in async_step_pair
   return await self._entry_from_accessory(pairing)
 File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 324, in _entry_from_accessory
   pairing.list_accessories_and_characteristics
 File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
   result = self.fn(*self.args, **self.kwargs)
 File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/ip_implementation.py", line 73, in list_accessories_and_characteristics
   self.session = IpSession(self.pairing_data)
 File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/ip_implementation.py", line 441, in __init__
   c2a_key, a2c_key = get_session_keys(conn, pairing_data, write_fun)
 File "/srv/homeassistant/lib/python3.7/site-packages/homekit/protocol/__init__.py", line 296, in get_session_keys
   ios_key = x25519.X25519PrivateKey.generate()
 File "/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/primitives/asymmetric/x25519.py", line 42, in generate
   _Reasons.UNSUPPORTED_EXCHANGE_ALGORITHM
cryptography.exceptions.UnsupportedAlgorithm: X25519 is not supported by this version of OpenSSL.
2019-11-11 12:13:47 ERROR (MainThread) [homeassistant.components.homekit_controller.config_flow] Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
 File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 278, in async_step_pair
   start_pairing, self.hkid, self.hkid
 File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
   result = self.fn(*self.args, **self.kwargs)
 File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/controller.py", line 374, in start_pairing
   raise AlreadyPairedError('Alias "{a}" is already paired.'.format(a=alias))
homekit.exceptions.AlreadyPairedError: Alias "AF:8C:F3:FD:D0:2D" is already paired.

Reasons.UNSUPPORTED_EXCHANGE_ALGORITHM
cryptography.exceptions.UnsupportedAlgorithm: X25519 is not supported by this version of OpenSSL.

Do you have any idea how to update OpenSSL 1.0.2o-freebsd to 1.1.1?

Thanks

@Dario_Lemes_Gonzalez – I’m not 100% certain but try this first.

iocage console homeassistant
pkg install openssl111

@troy,

Already tried that… No luck… Any other ideas?

Thanks

openssl isn’t looking very easy to solve. I don’t have anything homekit so it’s tough for me to test any trouble shooting. I did try going to the integrations and adding “HomeKit Accessory” It looks like any requirements install correctly (at least I get no errors in the logs) and at the end I get a notification “No unpaired devices could be found”.

I just wanted to double check are you sure the error you mentioned is not caused by this:

File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/controller.py", line 374, in start_pairing
   raise AlreadyPairedError('Alias "{a}" is already paired.'.format(a=alias))
homekit.exceptions.AlreadyPairedError: Alias "AF:8C:F3:FD:D0:2D" is already paired.

I’m asking because I don’t know if it will possible to make the upgrade to openssl.

Even after pkg install openssl111 – we are still getting this:

# openssl version
OpenSSL 1.0.2o-freebsd  27 Mar 2018

Then I found the thread below, which mentions there is no way to change base version of openssl. I suspect something very similar. The solution in this thread was to install openssl111 and then configure/install the app from ports with openssl111 enabled.

In your case though I’m guessing the homekit setup is expecting openssl version == 1.1.1 but to get that would mean changing the base version but that seems not possible. Only option might be having to wait for FreeNAS 12

Have a look at this. I think it’s very close. For this one you may have better luck making a seperate post in the FreeNAS forums.

I’ve reseted the device homekit and same errors. Factory resetted device and same issue.

Have a look at this. I think it’s very close. For this one you may have better luck making a seperate post in the FreeNAS forums.

Already did… no luck… any other ideas not to wait for freebsd 12?

Thanks

Maybe you can trick it using an alias

iocage console homeassistant
echo "alias openssl /usr/local/bin/openssl" >> /.cshrc
logout
iocage restart homeassistant

After following this guide I cant access my frontend even after followig your guide to install it…

I get the following in my log:

2019-11-12 22:37:44 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=97 from 2019-11-12 21:35:57.982509)

I tried to follow the guide two times, but still same result, same error message in log.

EDIT: Found this now: link that solved it

Hi Troy,
Firstly, thanks for your efforts in providing this info - great work. I just followed your scripted install and for me the front end GUI is fully accessible. However, there’s one thing in your instructions that isn’t totally clear to this complete noob. I’m trying to do the USB Z-wave passthrough. I’m stuck at the last step as I have no idea how to point my start-up script to the custom dev file. I can see the custom ruleset file in my root directory, but the Freenas console won’t let me point to it to create the script (“a file is required”). Probably a really noob question but what is the correct file path to this?

Worked perfectly. Thanks for the guide and for keeping it current!

No luck… same issue

2019-11-13 19:56:33 ERROR (MainThread) [homeassistant.components.homekit_controller.config_flow] Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 251, in async_step_pair
    return await self._entry_from_accessory(pairing)
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 324, in _entry_from_accessory
    pairing.list_accessories_and_characteristics
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/ip_implementation.py", line 73, in list_accessories_and_characteristics
    self.session = IpSession(self.pairing_data)
  File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/ip_implementation.py", line 441, in __init__
    c2a_key, a2c_key = get_session_keys(conn, pairing_data, write_fun)
  File "/srv/homeassistant/lib/python3.7/site-packages/homekit/protocol/__init__.py", line 296, in get_session_keys
    ios_key = x25519.X25519PrivateKey.generate()
  File "/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/primitives/asymmetric/x25519.py", line 42, in generate
    _Reasons.UNSUPPORTED_EXCHANGE_ALGORITHM
cryptography.exceptions.UnsupportedAlgorithm: X25519 is not supported by this version of OpenSSL.
2019-11-13 19:56:33 ERROR (MainThread) [homeassistant.components.homekit_controller.config_flow] Pairing attempt failed with an unhandled exception
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/homekit_controller/config_flow.py", line 278, in async_step_pair
    start_pairing, self.hkid, self.hkid
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.7/site-packages/homekit/controller/controller.py", line 374, in start_pairing
    raise AlreadyPairedError('Alias "{a}" is already paired.'.format(a=alias))
homekit.exceptions.AlreadyPairedError: Alias "16:FB:9A:AB:25:09" is already paired.

Thanks

hi troy, I’m having issues setting up the mosquitto service. I’m using some led lights through a arduino and the mqtt settings require a username and password. I’ve gotten this to work through vm based hass.io but i can’t figure out how to add usernames and password fields through the mosquitto.conf

Edit: i somehow got it to work by editing the mosquitto.conf and directing it to pull passwords from pwfile.

Please can someone help me fix my issues with adding the Zwave USB stick? HA is running on Freenas, if i SSH into it and use the command ls -ltr /dev/tty*|tail -n 1, it reports the following for my USB stick (it’s from zwave.me):
crw------- 1 root wheel 0x50 Nov 22 12:05 /dev/ttyv0

However, if I try to add the Zwave integration in the HA GUI and replace the default path (/zwaveusbstick) with /dev/ttyv0, it just reports the error “Z-Wave validation failed. Is the path to the USB stick correct?”

Can someone help please?
Thanks.