My steps to success for Hass.io on Intel NUC


#21

I’m moving from a pi to a Intel NUC. Would I be able to use the snapshot of my pi HA to restore on the NUC?


#22

@silfa718 It should do but I’d copy my yaml files offsite just in case.


#23

Is your NUC using Celeron or i5 chip? Thanks.


#24

Celeron processor


#25

@xbmcnut

Followed your guide and got my set up running in no time. Restored the latest snapshot from my pi install and everything booted up fine.


#26

@silfa718 Great to hear, thanks for the feedback. Since upgrading to the host OS version 1.3, my NUC has been a lot more stable.


#27

Hi guys,

Maybe a stupid question, but isn’t it overkill to run the hass.io version on a NUC? Cause you can’t run anything else besides hassio then…


#28

That’s how I feel about it


#29

I have installed ESXI on my NUC which runs several VMs. One of them is Ubuntu Server 16.04 on which I have installed HASS.IO using this.
Works great and has the advantage that you can indeed run a lot of other stuff on it :grinning:


#30

Agreed but,

My setup has out grown the pi I had running.

I needed a stable setup and had no real need to run anything else on it beside Hassio, and I didn’t have to mess with setting up something I don’t know much about. Anything I needed to run is available as an addon. NodeRed, Influx, Grafana…

But besides all that, the restart times have made the switch worth it alone.


#31

Easy method to me seems to be install a build of Linux with docker on the NUC, then run all your containers of all the various pieces and parts you need there. They all run natively with minimal resource usage of RAM, CPU, space, etc. If you need a whole other OS then run a VM of it alongside the docker. Kinda what I’m doing and it runs great. I’ve got about 15 or so containers on my little Xeon media server, the HA restart function is still crazy to me and has me spoiled for configuration testing, it’s usually restarted quicker than I can flip back over to the main view page.


#32

I didn’t want to manage an OS and wanted the benefits of the hassio add-ons. My NUC is older and only cost me $100 with 60GB SSD so not too much waste. I’m definitely over SD cards failures on the Pi and won’t ever go back their for a live system.


#33

On my Alpine Linux install on my NUC, I run apk update && apk upgrade about once a month. There’s nothing to manage for me.


#34

I just picked up a Celeron NUC (NUC5CPHY)

Dropped in a 120GB SSD drive and downloaded latest 1.3 nuc install of hassio, updated bios

It booted and the logo came up in under a minute it shuts off, all going good so far…

reboots shows the logo but no text underneath saying anything about 20 mins…just sits there 3 hours and nothing, can SSH into the device and cant see it on network.

I tried removing partitions on hdd, tried new usb stick with new download of 1.3 install


#35

So you can’t SSH? Assume you’ve tried a reboot?


#36

Yep tried to SSH into the ip address that my unifi controller says it is (hardwired)

Have rebooted a few times and no luck. I just tried reset bios to defaults and will try one more time before I give up for today


#37

Good luck.


#38

Some success …I left my old pi3 with hassio running and on the same network, think it was getting confused somehow.

I have now been able to get to it via the url and it says “will take 20 mins” pretty sure its been 30 mins but Ill keep waiting fingers crossed, pi took quite a while here also.

EDIT -finally completed after about 1.5 hours (must be my terrible internet) up and running thanks for the great post, gotta say everything just feels faster, even my zwave lights seem to react quicker.


#39

Well done. Keep hitting CRTL + F5 to force refresh. It should come up shortly.


#40

Did you ever solve the issue with the Bluetooth?
I’ve got 5 Xiaomi sensors that used to work in my Raspberry Pi that I havent been able to use with the NUC