Nabu Casa authentication failing

I had my HA instance working great with HA remote access through the Nabu Casa cloud, then after an update I had to change how I had my trusted networks in my config, and it hasn’t worked since. I get the message below - if I try local there is a choice to use local authentication but from outside the network there’s no choice just the failure message. Do I have to whitelist NC’s IP address or something?

You’re about to give https://(my NC ID).ui.nabu.casa/ access to your Home Assistant instance.

Logging in with Trusted Networks .

Login aborted:

Your computer is not whitelisted.

Here’s my auth config:

 auth_providers:
    - type: trusted_networks
      trusted_networks:
        - 192.168.1.0/24
    - type: homeassistant

Thanks!

Rob

You are ONLY allowing trusted_networks authentication and not normal authentication.

Add - type: homeassistant to the auth_providers.

They have it there but we cannot tell if there is a spacing error because they did not follow the directions for posting configuration here.

I have that in there - I have edited my post so you can see my spacing. It made a difference locally but no difference at all when trying from the internet.

I don’t know if it’s the right way to solve this but on a hunch I did a ping of the nabu casa server and added the IP address to the trusted networks and now it gives me the local login option from the interwebs. Is that bad or did I do good? I figured since my entire private network is trusted the only possible IP that could be coming in is NC’s or I guess my WAN IP but it appears to be NC’s.

Hi, are you still using this method or did you manage to find another way to whitelist nabu.casa?