Need Help: [HASSIO] DuckDNS is Configured but when Trying to Link IFTTT it Says "Home Assistant Needs To Be Accessible From The Internet"

I have tried every version of http(s) or not in my base_url line in the configuration, but every time I click on the IFTTT config it says “Your Home Assistant instance needs to be accessible from the internet to receive IFTTT messages.” and I don’t know what to do from this point.

Is your Home Assistant protected with a certificate and private key file?
Did you enable HTTPS:// security in your configuration.yaml file?
Is the 8123 port of Home Assistant forwarded to the correct IP address in your router?
Does your router support “NAT reflection” where it re-directs IP requests properly inside your LAN?

Sorry to ask so many questions, but each of these is critical, as IFTTT requires external ports to be open and forwarded properly to your Home Assistant port and IP address.

Here is my http: configuration block. I don’t use IFTTT, but this may help you

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
http:
  base_url: https://fredthefrog.duckdns.org
  server_port: 8123
  api_password: DontYouWishYouKnew
  ssl_certificate: /ssl/certfile.pem
  ssl_key: /ssl/privkey.pem

I just tried adding encyption in the DuckDNS file, and now I’m completely locked out of accessing hassio from my browser, both through my duckdns domain and locally. I can access the configuration.yaml file via samba, but removing the http settings doesn’t seem to do anything as I still can’t access it in my browser. As for the above, my configuration looked like

http:
  base_url: https://mydomain.duckdns.org:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

and I was able to access it just fine from my duckdns domain. Now I need to figure out how to get access back

Take the :8123 off your base_url, and put it on a separate line, as I have in my example above. :slight_smile:

Nope. Bricked it. Can’t even access samba anymore

I can however SSH into it, if that helps

Just figured out that I can use the Pi’s local address to get into configurator at port 3218, so I’m not totally locked out

If you’ve got configurator access, try to find the samba configuration file, and ensure the ssl: line says true.

I wouldn’t even begin to know where to look

I’m searching for mine right now, and can’t seem to find it, so you’re not alone. :wink:

in configurator, I went to /data/options.json and changed ssl to true and got back samba, but I still can’t access the UI

How can I change my DuckDNS data that I would be able to edit in the UI from configurator? What is the file location for the addons? My addons folder in samba is empty

Disabling port forwarding and deleting my http files in the configurator got me back into the local UI. According to this link https://github.com/home-assistant/home-assistant/issues/15579 SSL Encrypt is not compatible with this version of Hassio.

Sorry for all the posts, but I now have http configured through the NGINX addon, but still have the IFTTT issue that says it is not connected to the internet even though I am able to get into Hassio via the internet