Need help: Z-Wave JS to MQTT

Hex folks,

I need some help.

I get this Error-Message in the Z-WaveJS2MQTT Control Panel:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 
-----------------------------------------------------------
 Add-on: Z-Wave JS to MQTT
 Fully configurable Z-Wave JS to MQTT gateway and control panel; based on Zwavejs2Mqtt
-----------------------------------------------------------
 Add-on version: 0.32.1
 You are running the latest version of this add-on.
 System: Home Assistant OS 7.0  (aarch64 / raspberrypi4-64)
 Home Assistant Core: 2021.12.5
 Home Assistant Supervisor: 2021.12.2
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] configuration.sh: executing... 
[cont-init.d] configuration.sh: exited 0.
[cont-init.d] nginx.sh: executing... 
[cont-init.d] nginx.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[19:09:50] INFO: Starting the Z-Wave JS to MQTT...
/bin/sh: git: not found
2021-12-27 19:09:54.963 INFO APP: Version: 6.1.1
2021-12-27 19:09:54.972 INFO APP: Application path:/opt
 ______                       _     ___                  _   _   
|___  /                      (_)   |__ \                | | | |  
   / /_      ____ ___   _____ _ ___   ) |_ __ ___   __ _| |_| |_ 
  / /\ \ /\ / / _` \ \ / / _ \ / __| / /| '_ ` _ \ / _` | __| __|
 / /__\ V  V / (_| |\ V /  __/ \__ \/ /_| | | | | | (_| | |_| |_ 
/_____|\_/\_/ \__,_| \_/ \___| |___/____|_| |_| |_|\__, |\__|\__|
                            _/ |                      | |        
                           |__/                       |_|        
2021-12-27 19:09:55.033 WARN STORE: scenes.json not found
2021-12-27 19:09:55.081 INFO APP: Listening on port 44920 host 0.0.0.0 protocol HTTP
2021-12-27 19:09:55.157 INFO MQTT: MQTT is disabled
2021-12-27 19:09:55.183 INFO ZWAVE: Connecting to /dev/ttyACM0
2021-12-27 19:09:55.253 INFO ZWAVE: Zwavejs usage statistics ENABLED
[19:09:55] INFO: Starting NGinx...
2021-12-27 19:10:01.201 INFO ZWAVE: Controller status: Driver: Failed to initialize the driver: ZWaveError: Timeout while waiting for an ACK from the controller (ZW0200)
    at Driver.sendMessage (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:3345:23)
    at ZWaveController.identify (/opt/node_modules/zwave-js/src/lib/controller/Controller.ts:673:33)
    at Driver.initializeControllerAndNodes (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:975:26)
    at Immediate.<anonymous> (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:855:16) (ZW0100)
2021-12-27 19:10:01.206 INFO ZWAVE-SERVER: Server closed
2021-12-27 19:10:01.216 INFO ZWAVE: Client closed
2021-12-27 19:10:01.226 INFO ZWAVE: Connecting to /dev/ttyACM0
2021-12-27 19:10:01.243 INFO ZWAVE: Zwavejs usage statistics ENABLED
2021-12-27 19:10:06.586 INFO ZWAVE-SERVER: Server closed
2021-12-27 19:10:06.593 INFO ZWAVE: Client closed
2021-12-27 19:10:06.602 INFO ZWAVE: Connecting to /dev/ttyACM0
2021-12-27 19:10:06.616 INFO ZWAVE: Zwavejs usage statistics ENABLED
2021-12-27 19:10:11.862 INFO ZWAVE-SERVER: Server closed
2021-12-27 19:10:11.879 INFO ZWAVE: Client closed


I followed the instructions in the AddOn-Docs.

I wrote in the Z-Wave-Settings the same values I did in the Z-Wave-JS AddOn, but I miss the Field for the field for the network-key.

What is wrong?

cannot access zwave stick

You’re trying to use 2 addons at the same time? Because that won’t work. Otherwise try unplugging and plugging back in the controller.

1 Like

But I read, that I have to use both

Sorry, but that means you’re reading it different than it is intended. HA recommends you to use the official Z-Wave JS addon and not the Z-Wave JS to MQTT addon. Don’t mix up the words addon and integration by the way. You can disable automatic starting of the Z-WaveJS addon and stop it, then (re)start the Z-WaveJS to MQTT addon and see what happens.

I allready tried that, but the error still appears.

When I follow this video and enable port 3000 in the settings of the zwave2mqtt-addon, the integration switch to the right server-url, but with the connecion error I’m not able to reach the nodes.

When I first installed zwavejs2mqtt add-on, I would go to configure the integration and it was automatically installing the standard zwavejs add-on as well. When you install the zwavejs integration, there is a little checkbox that says “Use the Z-Wave JS Supervisor add-on?”. When that’s checked, it automatically installs the regular add-on in addition to the zwavejs2mqtt addon that you already installed. Make sure to uncheck this box.

My fix was to uninstall everything z-wave

  • Reinstall zwavejs2mqtt add-on.
  • In supervisor, set the zwavejs2mqtt add-on configuration port to 3000.
  • When configuring the integration, uncheck the box mentioned above.
  • Within the zwavejs2mqtt add-on webui settings, turn on “Disable MQTT Gateway” and “WS Server” and set the port to 3000. Set the correct Serial Port for your z-wave stick.
  • You should be gravy…

Some of the above steps may be done by default. I can’t recall for sure.

I don’t remember what error I was getting, but it was similar to yours. Hopefully this helps. Good luck.

Hi and thanks for your answer.

Do I have to integrate all z-wave devices again, when I uninstal everything?
Is there a possibility to avoid this?

If you already have a bunch of stuff set up, I would just go to the integration. Configure → Reconfigure Server. Make sure the “Use the Z-Wave JS Supervisor add-on?” box is unchecked. Then remove the zwavejs add-on that you don’t want. not zwavejs2mqtt. That should be roughly the same thing.

I was just setting my network up, so it didnt matter if it was all deleted. Aside from that, make sure the rest of the steps above are correct. I’m not an expert. Take this advice with a grain of salt.

I have read that you can copy over cache files that will preserve your entity and device naming but have yet to find a detailed guide on how to do it. Last time I tried, it goofed up all my 80 zwave devices forcing me to restore to a previous backup. Any tips on how to di this?

1 Like

Depends what you mean by “integrate” -
if you mean do you have to add all your devices to the ZWave network again, then no - ZWave devices are stored on the stick itself.

Okay, now I got it to run.

Unfortunately all nodes shown in HA are inactive.
In the Addon all are active?

What went wrong?

Now, I reinterviewed every device…

Bad luck: I cannot operate any entity

The devices will still be paired with the stick, but if the zwave integration is removed, the device names will all revert to stock.

@Baujahr70 All of the steps mentioned above are complete? Sorry, I can’t think of anything else.

  • In supervisor, set the zwavejs2mqtt add-on configuration port to 3000.
  • When configuring the integration, uncheck the box mentioned above.
  • Within the zwavejs2mqtt add-on webui settings, turn on “Disable MQTT Gateway” and “WS Server” and set the port to 3000. Set the correct Serial Port for your z-wave stick.

Okay, now after some hours the entities appear one by one

I think the zwavejs2mqtt addon is quiet slow compared to the official one

1 Like

The ZWaveJS2MQTT addon, runs the same (or slightly more up-to-date) ZWaveJS server as the standard ZWaveJS add-on. There is no reason that it should run any slower than the “official” one.

If i remove all z-wave, i install the zwavejs2mqtt add on, then when i click on the integration install I only get a pop-up without any ‘submit’ button