Neo Coolcam sos remote control wave +

Hello all, Just switched from domoticz to home assistant, so trying to find my way again. I Installed a zwave usb stick in home domoticz and is working fine with some components. I just received two neo cam remotes ‘sos 4’ remote with four key buttons. I added it ass secure node and all went well. Thing is i don’t know how to ‘map’ the keys. One thing is it doesn’t switch states, so can’t use simple automation. I know and read in the HA log that there were scenes but i cant find them in HA.

Is homeseer switches the way to go? (For the HomeSeer devices specifically, you may need to update the COMMAND_CLASS_CENTRAL_SCENE for each node in your zwcfg file with the following:)

Can someone point me in the right direction?

Thanx all,

Logbook
Showing entries for

25 mei 2018
19:12
changed to sleeping
19:12
Neo CoolCam SOS/Remote Control Emergency changed to 1
19:12
Neo CoolCam SOS/Remote Control SourceNodeId changed to 0
19:12
Alarm Level changed to 0
19:12
Alarm Type changed to 0
19:12
Sensor turned on

manual

Advanced Configuration
The following information is written to some people who have some experience in building a Z-Wave system or have a software that can run a Z-Wave master device or a Z-Wave alarm host. Be familiar with the Z - Wave master or Z - Wave alarm host before setting up.

  1. Basic Set Level

Basic Set Command will be sent where contains a value when SOS is triggered if group 2 have associated a device such as siren, the receiver will take it for consideration; for instance, if associated siren is received the Basic Set Command (0xFF), the siren will take alarm on.

0~99 are mapping to Basic Set value (0 ~ 99). 100 is mapping to Basic Set Value 0xFF.
Parameter Number Size Available Settings Default

1 1 0 ~ 100 100

  1. SOS Event Clear Time

This parameter defines the time to clear emergency event after emergency event is triggered when parameter #3 is set to ‘2’.
This parameter is set to ‘0’, the clearing emergency event will not occurred always.

The default value of this parameter is set to ‘60’, means that the emergency event will be cleared after 60 seconds when emergency event is triggered.

Parameter Number Size Available Settings Default

2 2 0 , 30 ~ 32767 60

  1. SOS Configuration

This parameter defines the SOS key function, the SOS key can be configured as emergency event key or central scene notification key.
If this parameter is set to ‘1’, the SOS key will be configured as central scene notification key.

If this parameter is set to ‘2’, the SOS key will be configured as emergency event notification key. The default settings is ‘2’, the SOS key is configured as emergency event notification key.
Parameter Number Size Available Settings Default

3 1 1, 2 2

Command Classes
This Sensor supports Command Classes as Below:

  • COMMAND_CLASS_ZWAVEPLUS_INFO (V2)

  • COMMAND_CLASS_VERSION (V2)

  • COMMAND_CLASS_MANUFACTURER_SPECIFIC (V2)

  • COMMAND_CLASS_DEVICE_RESET_LOCALLY (V1)

  • COMMAND_CLASS_POWERLEVEL (V1)

  • COMMAND_CLASS_BATTERY (V1)

  • COMMAND_CLASS_ASSOCIATION (V2)

  • COMMAND_CLASS_ASSOCIATION_GRP_INFO (V1)

  • COMMAND_CLASS_WAKE_UP (V2)

  • COMMAND_CLASS_NOTIFICATION (V8)

  • COMMAND_CLASS_SENSOR_BINARY (V2)

  • COMMAND_CLASS_CONFIGURATION (V1)

Got it working in Domoticz, at least the alarm button… Think I have to wait for the zwave events being implemented.

Any update?

I am able to see only the red button as binary_sensor, but no idea how to use the other 3 buttons

Idem !
Any update ?

No I left it in a drawer. Maybe the other buttons are events?

Still Just using one button to open my door with danalock.

Ok !
Thanks

Hi,

I’ve made it work in a usable way, which means that it’s still not exactly how I want it.

Basically the steps are…

  1. Edit your zwcfg…zml adding to the node(s) of your remote control the section for command class 91 as bellow.
  	 <CommandClass id="91" name="COMMAND_CLASS_CENTRAL_SCENE" version="1" request_flags="4" innif="true" scenecount="0">
  		<Instance index="1" />
  		<Value type="int" genre="system" instance="1" index="0" label="Scene Count" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="0" />
  		<Value type="int" genre="user" instance="1" index="1" label="Button 1 Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="3" />
  		<Value type="int" genre="user" instance="1" index="2" label="Button 2 Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="0" />
  		<Value type="int" genre="user" instance="1" index="3" label="Button 3 Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="0" />
  		<Value type="int" genre="user" instance="1" index="4" label="Button 4 Scene" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="0" />
  	</CommandClass>

Now you’ll be able to create your automation, based on binary_sensor for the red button, which I couldn’t make it work as scene, something related to control configuration.

But for other three buttons you can control 6 scenes with id’s 1 to 3, and scene_data 0 or 3.

For that just create the trigger:

  • Type: Event
  • Event Type: zwave.scene_activated
  • Event Data:
    entity_id: zwave.[your_id]
    scene_data: 0/3
    scene_id:1…3

The zwcfg edition must be with home-assistant offline…

Best regards,
Reiner

2 Likes

Today I configured a zwave remote with 8 keys the zrc-90eu. I also edited the 91 class as described in the home assistant docs. Works flawlessly. Now i see your post and will also edit the zwfcg file. So thanks no need to figure it ou myself. Five minutes later, first scene works!