Nest Integration Not Showing Devices

I am at a loss here and am not sure where to go. I had the integration working great and then I had an issue with Home Assistant where I had to delete the database and recreate it. Since then this integration has not worked properly. I walk through the set up steps when I add the integration and it sees the thermostat, but once it is added it does not show any devices. I have tried the following:

  1. Deleting the integration and re-adding it
  2. Recreating the OAuth credentials and updating the config in Home Assistant
  3. Deleting the entire project in the Device Access Console and the Development Console
  4. Recreating everything following the steps exactly in the documentation.

I understand there are some more verbose logs, but have not found where I can turn them on to find out what is happening and would be happy to provide them here once I do find out.

Let me know where I should go from here, thanks all!

I turned on the logging as stated in the documentation on the integration:

logger:
  default: info
  logs:
    homeassistant.components.nest: debug
    homeassistant.components.nest.climate_sdm: debug
    google_nest_sdm: debug
    google_nest_sdm.device: debug
    google_nest_sdm.device_manager: debug
    google_nest_sdm.google_nest_subscriber: debug
    google_nest_sdm.event: debug
    google.cloud.pubsub_v1: debug
    google.cloud.pubsub_v1.subscriber._protocol.streaming_pull_manager: debug

And I did not see any entries in the log for the integration. Is there some file or something that is causing an issue that would need to be deleted or something else weird going on here? Thanks.

Someone on Reddit gave me this tip. Try going into the app and moving one of the t-stats to a different room then reload the integration.

You can then move the t-stat back to the original room.

1 Like

Dude you are awesome! I can’t believe something simple like that worked! Thank you! Not long after you posted this I also saw the Reddit post where multiple people claimed it worked as well. Thanks again!

Doesn’t work for me!

Hi @backslashv – what is the problem you’re having?
See instructions at https://www.home-assistant.io/integrations/nest/#troubleshooting for troubleshooting and let me know what the symptoms are, and what you’ve tried. We’ll figure it out.

Hi, the problem is that devices from the nest integration suddenly become unavailable. This is, most likely, an issue with the integration from Google. The only way to fix it is to remove and relink the integration. A lot of other people have the same issue.

@backslashv There is an issue where thermostats disappear and either come back when you restart them or move them between rooms in the nest app or google home app – then just restart the integration. Does that sound like your issue?

Yes, that’s the issue. However, neither restarting HA nor changing rooms works.

In the common cases reported, the thermostats are missing and not returned from the API.

In my case, restarting the actual thermostat itself resolved the issue (followed by a home assistant restart), however that appears to help other folks less commonly.