Netatmo integration works, but only partially

Hi I need some help with setting Netatmo integration properly.
On my Netatmo account I have weatherstation, a Welcome camera, and couple of Presence cameras.
I don’t have any issues with the weatherstation (I have readings from all modules, including rain and wind gauge), I have streaming from all cameras visible.

What I don’t have is manging the lights of the presence cameras (the switches are on the dashboard but they are greyed out and marked as “unavailable”, and I can’t use triggers from the cameras (they are available in the automation UI, but never worked).

For the light control, it worked once for a short time (surprisingly, some time after I installed integration), but now they are not working again.

As I searched the forum, it might have to do something with webhooks (at least for controlling the lights), but the advice I found is about resetting webhooks, which - frankly speaking - I don’t know how to perform.

I’m not very familiar with the “programming” part of stuff (most of the time I use GUI) so I need some step-by-step help for dummies on what to check and how to do it

No one knows?


I have some issues since the last update of my home assistant this morning.
Entity has been changed and like you, i have no light control.

In my case it was like that from the very beginning, I just didn’t have time to finally work on it.
There was one time when it worked (at least lights), but it stopped very soon.

Some update - surprisingly, today I see I can control Presence lights again.
I don’t know if this is due to recent HA core update or something else.
But still I can’t use Netatmo related triggers, at least not as Device → camera event (like person seen, animal seen, etc.)

Other surprising thing is that my camera stream entities were re-created (I had the old ones marked as “inactive” and not supported anymore, and new ones working properly per each camera)

After HA restart my light controls are greyed out and marked as unavailable again :confused:

Yes Indeed, it’s ok for me for control light since the last update 2023.6.1.

For stream entity same for me Yesterday, but there IS a New updated entity and it’s seems to works fine for me right now).

For me it doesn’t work anymore after HA restart, even after update to 2023.6.1
The streaming is OK, but it always was (except the yesterday’s change in entities)

1 Like

I just updated to 2023.6.1 and my Netatmo Thermostat stopped working with error “This entity is no longer provided by integration”

any clue on how to repair it? never happened before

Now I’m really confused.
For testing purposes I set up the automation that if one of my Presence cameras will see a person, I will get notification.
And yesterday it worked. Twice.
Then stopped again.

I didn’t change configuration or touch anything during that time. It seems that it has it’s own life and works or not at random.

Really, its only me who has such troubles or no one uses the Presence camera for triggering automations?

Hi everyone,

Since the last version of HA, I having problems with the Netatmo Integration which had been working fine for several month. Since one of those updates, I have unavailability issues with some entities. I decided last week to try to remove the Netatmo integration, and since I can’t reinstall it. Of course, I went to the Netatmo account to remove the App from the Partners Application. The result is that most of the time, the link (authorization) between HA and Netatmo fails, when it doesn’t fail and say Done, I still don’t see the Integration in the config. I just see a short message saying re-authentication success. I have been spending nearly a week on that, with no success and a lot of frustrations. I could not find any help on the various forums or blog. It seems that even when the integration is un-installed, some parts stay. Any idea or suggestions folks ?

So in my search to try to fix the logbook for netatmo I removed the integration and added it back and now its not working cant authenticate, and when I restored a snapshot it keep reinitializing. Waited few days and still same. Any ideas how to fix ? All entities are unavailable only have the weather station.

I wonder, is still somebody managing that integration?

The stream of the camera is gone all 2 to 5 minutes. It has become extremely unreliable. I wonder what’s the reason: HA update or Netatmo? As it worked before a while, I assume it’s a problem of HA.