[NEW ADDON] Simple Scheduler

Tags: #<Tag:0x00007f739721e8e8>

Hi Alessandro, I am fairly new to HA and for my controller, I did not have to do manual config as it is automatically added to HA using MQTT Discovery and is managed by MQTT messaging. Best would have been if SimpleScheduler could support climate control, based on features provided by the standard climate control (minimum is mode + temp). I understand that it may be a considerable effort to add this. In the mean time, is it possible to at least define the mode? Or instead, send predefined strings for on/off? And if not possible, can you help in instructing me how to build this automation but in a way that also the device ID (or whatever it is called) will be passed to the automation and be used for sending the commands to the correct device? In that way, I will need to add this only once for all my connected devices. And BTW, 3 Beers are on their way to you :slight_smile:

You can create two (or more) script like this one:

script:

  turn_on_heat_27:
    sequence:
    - service: climate.set_temperature
      data:
        entity_id: climate.bedroom_ac
        temperature: 27
        hvac_mode: heat        


  turn_on_cool_24:
    sequence:
    - service: climate.set_temperature
      data:
        entity_id: climate.bedroom_ac
        temperature: 24
        hvac_mode: cool  

And then in SimpleScheduler turn on the script you need.
To turn it off, you don’t need to create a script, you can just turn off the climate.

If you want the climate to be parametric, there are many ways to send the parameter. In this example, I’ve used an input_select, but it could be a text_sensor, a template_sensor, etc… The code is still the same:

  turn_on_cool_24_param:
    sequence:
    - service: climate.set_temperature
      data_template:
        entity_id: "{{ states('input_select.climate_list')  }}"
      data:
        temperature: 24
        hvac_mode: cool     

Those are not random from the internet.
Both those examples are tested and they came from my configuration environment.

Cheers to you, my friend! Have fun!

how does one get this running in home assistant core (aka home assistant in a docker)

As in FAQ:

Last line:

Be aware that add-ons are only available in regular Home Assistant installations

aka you can’t!

There is a non addon option you could use:

1 Like

perfect I will go investigate right now.

Hi. I have a wifi switch connecting my electric heater. I wanted to have it “ON” & “OFF” 4 different times of the day. With the Simple Scheduler, I have to create 4 different schedules. Is it possible to specify 4 different times on the “ON” & “OFF” time entry? Also, is it possible to give the schedule a custom name rather than the switch name it picks up? Thanks

Sadly, it is not possible.

Hi,
thanks for the practicality of this addon.

I’m now struggling with the following - I use it to control a climate entity. I have a schedule to turn on every day at 08:00 and turn off everyday at 23:00.

The issue comes if someone manually turns off the thermostat lets say at 10:00 it wont turn back on via the scheduler.

Is there a way to make it persistent? meaning that after the climate is turned off manually, the scheduler turns it back on after X minutes since we have a schedule that it should be on from 08:00 - 23:00

Hi, i’ve installed Simpel Scheduler but get a error when starting, What is it that is going wrong: Warning : file_get_contents(/data/options.json): failed to open stream: Permission denied in /var/www/html/lib.php on line 11

It is strange, even on a new fresh install of Home Assistant i get this error. Strange.
Warning : file_get_contents(/data/options.json): failed to open stream: Permission denied in /var/www/html/lib.php on line 11
This error is on a Pi the other was on a NUC. I did a next, next finish install on both systems.

Is there somebody who can help me with this error?

Have the same problem ass MRRV worked grate untill a moment ago

1 Like

Something must be different in the new docker images because it seems to me that only the new installations got this issue. On old installations, the scheduler is working flawlessly even after an update.
I have to run some tests… :thinking:

1 Like

I also got an error when I upgrade to home assistant version 0.116. Hope to have a patch for this add-on soon. Thank

I figure it out.
As I suspected, something has changed with the new versions.
I’m currently working to fix that.
Thank you for warning me.

1 Like

Your add-on has helped me a lot for my smart home. Thank you for creating it.

3 Likes

i love the add-on so far ^^ will ceep my eys out fore the patch :slight_smile:

2 Likes

Fix released!

3 Likes

Thank you!