New custom component : ZiGate


#242

I am facing issues whenever I try to control Ikea bulbs with Google Voice Assistant. There are no problems to turn them on. However, whenever I try to switch them off most of the messages are lost. Meaning that Home Assistant tells a certain state (lights are off) but the real state is completely opposite (lights ar still on).


#243

You should keep the same version as the one used by HASS. Then you should do pip install -e which will override the ordinary one plus that you won’t need to do additional installs when you do changes. It would be as simple as do change and then restart hass


#244

Hi,

I succeeded to integrate a xiaomi round button, so I know my zigate is working fine. Now trying to integrate a Hue White bulb. I resetted the bulb with the Hue remote (the bulb flashed) and I got it joined to the zigate network (received the notification on hass home screen).

Then I added this to my configuration.yaml:
light:
- platform: zigate
name: lampe_bureau
address: “38f901”
light_type: dual-white
default_sate: event

I then restarted hass. When I toggle the light button on hass web ui, this does nothing.

Maybe I use the wrong end point? I’m not sure if the end point should be always “01”. Is it? If no, how can I find the right one?

Thanks.


#245

This is my first zigbee device for my brand new zigate, were you able to make it work ?
Thanks for sharing. :slight_smile:


#246

Yes, first you have to put the zigate in pairing mode and pair the switch (just like with the xiaomi gateway).
Then I used this code:

switch:
  - platform: zigate
    name: 'Floor Uplighter Power'
    address: 3bcf02
    default_state: 'off-release'
    type: 'toggle'
  - platform: zigate
    name: 'IKEA Furry Lamp Power'
    address: 3bcf03
    default_state: 'off-release'
    type: 'toggle'

#247

Thanks very much. I was able to make it work just like this:

  • platform: zigate
    name: ‘Cuisine central’
    address: “37b701”
  • platform: zigate
    name: ‘Cuisine table’
    address: “37b702”

What does it change to add default_state and type ?


#248

Honestly? I’m not sure ^^ I was just trying out some combination until it worked :slight_smile:

They might be not required for this type of switch.


#249

OK now I’ve found that switching manually the switch on the wall turn on the light but the state does not change in HA.
I tried to add your complete config adding default_state and type but it does not change anything.
Any idea?


#250

State is reported in endpoint 4 and 5.


#251

Sorry but I have absolutely no idea how to integrate endpoint 4 and 5 in my config.


#252

Replace the 2 last digits of the address (i.e. xxxx01 becomes xxxx04 or xxxx05). You may declare both if you plan to use the 2 switches


#253

Does this (replacing endpoint) to solve the issue on github that lights are not reporting state back to HA?
I tried to pair one of my Tradfri bulbs to Zigate but it was not reporting state and I turned back to Ikea gateway. Maybe I didn’t configured properly endpoint (don’t remember), but will try again with another endpoint if lights report its state


#254

I’ve tried this

light:
 - platform: zigate
    name: 'Cuisine central'
    address: "37b704"
  - platform: zigate
    name: 'Cuisine table'
    address: "37b705"    

And nothing is working anymore.
Do I need two entitites ? one for the light and one for the state ?
Sorry but as I saied it’s my first zigbee experience, I never used the xiaomi gateway.


#255

You’re right, for now you need two entities per switch, the 4/5 for the state and the 2/3 to control the light.
It’s not really perfect yet. I didn’t keep the state endpoint in my config because I didn’t need to know the state.
I suppose they should be configured as sensor, but I don’t have the exact config anymore.


#256

Ok I have to find how to do that.
But on my wall switch I use 01 and 02 to control the lights. not 02 03. (I’m using the double key with fire line)


#257

Maybe a noob question… but I’ll ask again… how do you find out what is the endpoint number to use? The device id is easy to find… but not sure about the endpoint id…


#258

Here you can sees the command used to get a lost of endpoint:


#259

It’s a little bit dead here :slight_smile:

i’m trying to run every hour the getDevicesList methode in order to get Link quality of all devices. ( by automation ) Link quality information received will be added as attribute.
rssi

With grafana and influxDB information will be stored. I suspect RSSI(link quality) to be wrong.
by the way, if someone knows why information are not automaticaly pushed to influxdb ( rssi and last seen updated but information not pushed )

Need more tests to be pushed to the repository.

EDIT : it seems when attributes changes : no update is sent to influxDB, default state has to be changed to be pushed


#260

@eLRIC is RGB possible with lights? I have not been able to enable it…


#261

Rgb doesn’t seems to be supported in the current code version.