New custom component : ZiGate


#141

I seem to have solved my random disconnection issues by running HA on a spare Tinkerboard i had lying around. Been working for almost two weeks without issues so it’s looking good.

I do have an issue with my Philips hue lights though: they were paired with the zigate before i switched to the Tinkerboard, but I cant figure out how to reset them to re-pair. From what I read it’s just not possible (which seems rather silly), outside of buying a philips hue bridge. Does anyone know of another way to reset them?


#142

i’m still having issues with my body sensor :frowning:
I will need the RSSI value to investigate :slight_smile:
I will also test with an other body sensor.

Edit : same issue => interference :frowning:


#143

I’m using my zigate from a remote server and I use ser2net to provide the access to the device. On hass side, I’ve configured the zigate component with host/port arguments.
It looks like the plugin doesn’t handle reconnects. it doesn’t reconnect when it looses the connection, I’ve just filled a github issue about it.


#144

Update: everything is working now. The update to the most recent ZiGate version (3.0D) helped me to solve pairing issues. Thank you!


#145

Guys can you advise me how I should configure Xiaomi Socket/Smart plug (ZigBee) in order to get it working with ZiGate?


#146

Known working configuration examples added on the github wiki :


#148

Hi,

Just upgraded to hassio 064 and it seems my zigate integration isn’t compatible. These errors show up in the log.:

Invalid config for [sensor.zigate]: string value is None for dictionary value @ data[‘default_unit’]. Got None. (See ?, line ?).

Invalid config for [switch.zigate]: string value is None for dictionary value @ data[‘inverted’]. Got None. (See ?, line ?).

Invalid config for [zigate]: string value is None for dictionary value @ data[‘zigate’][‘host’]. Got None. (See ?, line ?).


#149

Have you downloaded newest version of ZiGate integration from Github? If not then download it. If you have then I need to look it again and see why it’s still giving errors.


#150

it’s not automaticaly download by the component ?


#151

i don’t think so.
You should be able to do : pip install --upgrade git+https://github.com/elric91/ZiGate.git
(not something I have tried myself, I have git cloned it and pip install --upgrade /path/to/cloned/ZiGate)


#152

I’ve updated the ZiGate integration with the pip command @lolorc posted above, but HA is telling me I have invalid config in my yaml:

General Errors:
- Setup failed for zigate: Invalid config.

So either the update process didn’t work or there is a problem :slight_smile:


#153

I think there were changes in 064 that require some adjustments by components. Not sure though. Reason I think is that others report similar issues for other components.


#154

Sorry, I meant to say that are you using latest version of zigate component? If not then download it from github. I am not sure is there new release with fix. If not just download code.


#155

Sorry, turns out it was my own fault. I updated the code, but somehow missed updating the init py file. :kissing_closed_eyes: Works like a charm now


#156

I upgraded to the laster version of pizigate and home-assistant plugin.
I think there is an issues :
There is a 0.1.3 release of pizigate githup but in the setup.py is still 0.1.2 : )

How to use the getContactList ?
I tried to use send by zigate.raw_command ( but it’s not working ) :
{
“cmd”:“0015”
}

How to get illuminance value ( of the body sensor ) ?
thanks a lot !


#157

You can change your zigate/init.py and simply modify 0.1.2 to 0.1.3
Then restart HA, it should do the trick !
(you need to have ZiGate’s firmware at least 0.3b for it to work)


#158

I have experienced multiple disconnects of Xiaomi sensors and buttons multiple times. Is this a known problem?

I would love to know the above as well, I’ve seen the attribute inside the testGUI; but I’m not that well versed yet in the zigbee docs + python to find it myself :confused:


#159

I already change the version number.
But no “getcontactlist()” or illuminance. That’s why I’m asking here :slight_smile:


#160

Same here, I’ve experienced disconnections as well with both my xiaomi sensors and osram plug.
I would say that it losts connection to every sensors. I just had to restart HASS to get them come back, so I guess it’s not an issue with the firmware but with the homeassistant_zigate component.
Unfortunately I lost the log file when I restarted HASS. (since I don’t have them I can’t say it wasn’t a network connection issue)


#161

I could be wrong, or that im just not seeing it… but,
it appears that the python library is still at 0.1.2 inside the setup.py for the project.
so changing the version number inside the hass component to 0.1.3 just breaks it for me (“could not be set up”)…
Installing the python library by cloning the repo and installing from there or installing with a direct link to the repo as stated a bit above here, installs a 0.1.2 version (with the illuminace cluster support added in the code). with the pip command from the repo it appears to install 0.1.3, but then changing the required version in the custom component to 0.1.3 still breaks it.

keeping the version on 0.1.2 together with the most recent commit works, but for some magical reason it will not show illuminance.

Hope this helps even a little bit. I’ll be trying further :slight_smile: