New Hass.io images, based on HassOS


#166

My issue turned out to be a bad network cable. Doesn’t make sense since I just had the system up and running on that cable - but swapped it out and everything works now.


#167

Can I access to boot partition?
We need to activate onewire! Can you help?


#168

sure, thats not the issue.
the thing is that steps 7 and 8 are not exactly as described, and hassio.local:8123 can’t be reached, while the ip address can.

btw, to distinguish the new HassOs from Hassio, it would be a nice touch if this would be hassos.local…


#169

It’s still Hassio though. The old name wasn’t resinos.local. :thinking:

If your network doesn’t support mDns, the local hostname thing wont work. It’s not a big deal. Not all networks support it. Or it might work intermittently. In the end it is just a bit of friendly fluff to make something technical appear less technical and I prefer the ip in all cases because that’s what I’m used to. Why not be direct, is how I see it. There’s a note about this on the actual install page and it has been there a while. The mistake was laying out yet another source of instructions in a blog post instead of linking to a page.


#170

A computer resolving or not resolving hassio.local has nothing to do with hassio


#171

must have missed that. and btw this is on the actual install (getting started) page:

Home Assistant will be available at http://hassio.local:8123. Shortly after the download has started, a simple preparation status page will be available at this URL. Point your browser there. The page refreshes automatically, and Home Assistant will be shown when the download is complete.

seen nothing of that. and when clicking the ip address, I see the first Hassio page. No preparation page at all?


#172

That is something you should ensure on your DHCP server.


#173

Yep. I had this one in mind (hassio) https://www.home-assistant.io/hassio/installation/

And that’s what I meant by “yet another” …there should be one page with instructions to maintain. Not 3. :crazy_face:

Edit: There also shouldn’t be partial instructions like “Make a folder called network/my-network…” and then linking to the actual page where the full instructions are. We should just say “For networking configuration, go here” and provide the link.


#174

same thing:

You will be able to reach your installation at http://hassio.local:8123.

didn’t happen, reason of my first post.


#175

YES. Your network didn’t support that. You have mentioned this several times. It is understood.


#176

Is this a change from the resinOS version of hassio? I used to be able to hit hassio.local:8123 but now on hassOS I had to use the IP? It’s no biggy, just more out interest than anything.


#177

sure it does.

02

must be another setting somewhere.


#178

Again, it’s not hassio. It is your network not supporting this.


#179

im trying to understand. really. Thats why I posted the network displaying the hassio.local for the regular Hassio install, and the ip address for the new Hassos install.
the router sees this:

34

Are they implemented differently then?


#180

Wait, are you expecting two http://hassio.local to appear?


#181

well, yes, tbh I would love to have both installs in the browser, which shouldn’t ne such a unique situation :wink: having more than 1 hassio install.

just as i ws checking I tried this: hassio-2.local:8123, and it appeared…

43
I would have hoped that by setting the name to hassos in the samba add-on, i could have made it into hassos.local, but that doesnt work apparently


#182

Discord channel or another post is probably a better place to explore avahi, mDNS, samba etc. I feel a little bad about extending this discussion out on this particular post.


#183

sorry if I was the cause of that.
otoh it might be a valuable addition to the regular setup instructions, to point people with multiple installs to the option of numbered hassio.local instances in their network.


#184

So you’ve finally accepted it’s just user error?

Given you have always been able to access any instance of HA, hassio or otherwise, at device_ip:8123 this is a total non issue. Hassio.local doesn’t work on all devices anyway which is why it says to use the IP on that instance, it doesn’t on any of my android devices for instance.

I’m assuming the devs were trying to be helpful to newbs setting up their first instance that may not have known the device IP straight away, if you have multiple instances of HA and therefore been there before you should know better :slight_smile:


#185

They have just received donations for a NUC to start developing…might take a while longer but its on the cards