New 'unique' ID's for the same Entity's after HASS restart

Hi there,

I’m new here and struggling time after time (two weeks now) with lost entitie in the UI webinterface. After discover i can add the new motion and temperature entities (433Mhz via RFXcom) to the lovelace view. After a while when i restarted hass.io then I see yellow lines with the text “Entity Not Available”. A restore of the complete backup is no fix, the only way is to asign new unused entities which had an other Entity ID number. :thinking:

See the sample below which i found in the customize.yaml file after I changed the friendly name via the webinterface. Is there someone who can help me here, thanks in advance.

KlikAanKlikUit Motion Sensor

1e time
switch.0b1100390059c3b60a010f80:
friendly_name: Motion

2e time, after restart HASS
switch.0b11003d0059c3b60a010f60:
friendly_name: Motion

3e time, after restart HASS
switch.0b1100000059c3b60a010f70:
friendly_name: Motion

2019-02-15%2022_26_34-Start

2019-02-15%2022_11_41-Start

The adjustment of the device name also gives an error message like here, but it is written in the customize.yaml

2019-02-15%2022_13_40-Start

Nobody? :thinking:

did you follow the directions in the documents? It says to do this first:

switch:
  platform: rfxtrx
  automatic_add: true

Then once you get the names you need to hard code them and remove automatic_add: true

switch:
  platform: rfxtrx
  devices:
    0b11000102ef9f210010f70:
      name: device_name
1 Like

I’m experiencing the same problems. @proza have you managed to fix your setup?

Now I am struggling with the same problem ?!
Has anyone solved this ?

Did you follow the directions?

Think so :slight_smile:
But now I think I solved it.
Did this:
automatic_add: false
devices:
0a52010550010110190260:
name: 433_vardagsrum
data_type:
- Humidity
- Temperature

Now I have to figure out how to get a switch working that I only have House and Code to, but no remote