New user installation, can't connect

Hi everyone, first time user here.

Have downloaded image for a new Raspberry Pi 3B+. Used the recommended 32 bit image. Have added network details to USB stick and booted. Pi is visible on network and i can ping hassio.local. However there are no open ports on the pi and i cannot connect via browser to port 8123. Have left overnight and no progress.

Not sure how to go about debugging the problem as i cannot ssh into pi.

Any suggestions please?


Tried clearing the browser cache?

Just cleared caches and still refuses connection unfortunately.

Okay, here are a few things that I tried when this happened to me:

  1. Clear browser cache or try another browser. Connect to the IP address not the mDNS name.

  2. Make sure that your power source is at least 5v at 2.5amps (this thing is power hungry) and use a proper PI power source, not a smart phone charger.

  3. try swapping out the SD card with something that’s high quality. (this was my problem) SD card could not handle the disk IO.

  4. you have an HDMI monitor or TV, try plugging it in and seeing what the output is saying.

BTW, are you not seeing anything (white screen? error?, partial interface?)

Have you tried connecting to the IP address, like ?

Steve, yes I have tried the IP address and no difference. Thanks

Thanks for your suggestions. I’ve tried both Safari and Chrome browsers with caches cleared. Using a high quality Sandisk SD card. Have swapped power supply to 40W dedicated. Unfortunately I don’t have a monitor/keyboard - running headless so not seeing anything!

what do you see in your browser? blank? error? Have you tried reinstalling?

Your Sandisk is a class 10? How much space does it have?

Wouldn’t matter. There’s nothing on the screen to see but a big blue logo (if I recall). HassOS is meant to be headless- (I am assuming that you downloaded the image file here: ).

Yes that’s where I downloaded image from. I’ve now downloaded the 64bit image and so far same issue after approx 1 hour post boot. I’m running another Raspberry Pi with Raspbian and no problems.

I am going to ask a silly question here. Did you restart the Pi?

Yes, I’ve restarted several times. Overnight I’ve tried 64 bit image with exactly the same results. I’ve booted a standard Raspbian image on this new Pi and it works fine. Thanks again for your suggestions.