Newbie question: several devices with same configuration/binary flashed

Hi all,

I just installed Home Assistant this week on a Raspberry Pi 4, so assume zero Home Assistant background knowledge from me. However I always prefer Ubuntu over Windows and I’m pretty much into Python stuff, so I have quite some IT background knowledge.

I just ordered four Gosund SP1 smart plugs to use them with Home Assistant via ESPHome. So I followed the instructions from here, using a second Raspberry Pi 4, running Ubuntu Server 18.04. The first plug I unfortunately flashed with the Tasmota firmware that shipped with tuya-convert (should be easy to recover). For the second one I used the configuration from 3.3 here, compiled it within ESPHome in Home Assistant and flashed it. That worked perfectly fine. I can now control the plug and read the sensor values within ESPHome. So I flashed the third one with the same binary as the second. However ESPHome / Home Assistant did not discover that one, even though it is properly connected with my WiFi and therefore should be flashed properly.

I guess I am not supposed to have two devices with the identical name in ESPHome? If so do I need to change “esphome/name” in the configuration file and build a new binary? And how to recover the third device which doesn’t show up? Or is the issue somewhere else?

Thanks a lot!

Same name should not be a direct issue, HA will add _2 at it.

Have you flashed static ip? Or dhcp?

You can find the ip in your network via the device that gives dhcp adresses out. And then in HA via integration - add - esphome add the esp device using the ip adress.

Ech esphome address is a separate integration.

Great, thanks a lot. That was easier than expected and works fine.

One more question here: I renamed the devices in configuration/devices to " Gosund SP1 Smart Plug 1" and " Gosund SP1 Smart Plug 2". That worked, but it warned me that the new names wouldn’t be applied everywhere. And yes, in the dashboard there only appears one of the two devices (“Gosund SP1 Smart Plug”), and in the history I have only one switch (“Gosund SP1 Smart Plug”), but two voltage/wattage sensors, “Gosund SP1 Smart Plug Voltage” and “gosund sp1 smart plug voltage”. How can that be fixed? I can’t see any renaming options there.

EDIT: It seems like the second plug is not integrated properly. The first one shows the following entities:

  • Gosund SP1 Smart Plug
  • Gosund SP1 Smart Plug Voltage 226.5 V
  • Gosund SP1 Smart Plug Wattage 0.0 W
  • Gosund SP1 Smart Plug current 0.00 A

but the second one only:

  • Power Button Off

Make all naming correct in the esphome fimwares. Delete the 2 integrations and add them back.

1 Like

Yep, in the integrations page, remove and then readd

Thanks and sorry for not replying earlier. So I have to first remove all from ESPHome, then change the configuration and compile a separate binary for each plug, flash them again and then re-add them into ESPHome?

How can I then flash these binaries on the already flashed plugs? Just uploading via ESPHome doesn’t work out - it compiles the binaries, but doesn’t find the plugs.
OR how can I bring the plugs back in pairing mode to flash them again via tuya-convert?