Nginx on hass.io on a pi 4

I have a fairly typical setup at home (I think). I have my internet provider’s router (AT&T) with a google wifi plugged into it. There’s some AT&T crap plugged into the AT&T router but everything else is plugged into a switch hanging off the Google WiFi. All wifi devices are connected to the Google wifi. From outside my home, I’d like to be able to access my home assistant, running on a pi 4 using hass.io. I got this working using duckdns and nginx but I had to remove a port forward rule in mt AT&T router since it was forwarding 443. This broke the AT&T crap plugged into the AT&T router (two remote TV boxes). I deleted the port forward rule I added for Home Assistant and added the other rule back which fixed the remote TVs.

I’d like to use a different port than 443 (let’s say 1443). How do I configure nginx to get this to work? Alternatively, is there some combination of port forward rules I could set on the AT&T router and my Google WiFi to get this to work without touching nginx?

It doesn’t look like the DuckDNS addon has the ability to change ports. With the NGINX addon, there is an option to set the host ports. You may have better luck with that, but you’ll need another solution for dynamic DNS

Don’t I just use https://xxxxduckdns.org:1443?

Yes, you’ll use that, but in order for NGINX to know to serve SSL from that port, you need to map it somehow. If your router is capable of mapping 1443 to 443 internal, then you can go with that. If not, you’ll need to do the mapping on the RPI, which the NGINX addon can do.

That’s my question. I want to change 443 to 1443 in NGINX and don’t know how.