NGINX Proxy Manager won't start post 2021.12 Upgrade

Upgraded to Version 2021.12 and all of a sudden NGINX Proxy manager won’t start. I have tried uninstall, reinstalling etc. However I can’t get it to start and stay started, etc.

s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] permissions: applying…
[fix-attrs.d] permissions: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] executing…

Add-on: Nginx Proxy Manager
Manage Nginx proxy hosts with a simple, powerful interface

Add-on version: 0.11.0
You are running the latest version of this add-on.
System: Ubuntu 20.04.3 LTS (amd64 / qemux86-64)
Home Assistant Core: 2021.12.0
Home Assistant Supervisor: 2021.12.1

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] exited 0.
[cont-init.d] executing…
[cont-init.d] exited 0.
[cont-init.d] executing…
[23:05:21] ERROR: This add-on now requires the MariaDB core add-on 2.0 or newer!
[23:05:21] FATAL: Make sure the MariaDB add-on is installed and running
[cont-init.d] exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

1 Like

What is not clear in the error message?

The services are started, HASS is configured to use MariaDB, MariaDB is installed and running.

So I guess why can every other AddOn that needs MariaDB Access it, except for this one.

What’s the version of your current MariaDB addon?

Version 2.4 - Shows no available updates either, so assuming that is current for HASS

This is actual for me as well due to 80 is buzy: by armv7-hassio-observer

25f4e68eb85f        "/init"                  3 weeks ago    Up 3 hours>80/tcp, :::4357->80/tcp   hassio_observer

It was open there and before the update but only after the update it failed…

I’m actually hitting the same issue since a few weeks ago. Although MariaDB is up & running, and being consumed by other services, nginx proxy manager simply fails on its MariaDB connection not being available.
Restarting the mariadb addon, and than starting nginx again is the workaround atm.

Looking at the logs of both add-ons, there isn’t much to go on.
Strange, since it used to work flawlessly before.

I’m just starting to use Nginx through HA for the first time, and following the installation instructions, it says:

  1. Ensure you are running the MariaDB add-on. This add-on is required to use the Nginx Proxy Manager add-on as it uses the database services provided.

I installed that (Settings >> Add-ons >> ADD-ON STORE >> MarinaDB), gave it a password, started it and now Nginx is working fine - Admittedly, I haven’t had it installed before, nor have I configured anything in it, so my success might be because it’s clean.

Disable watchdog for both. There’s a bug currently around this.

1 Like

Thanks! Disabling the watchdogs worked for me!

How do you disable the watchdog?

Its a toggle on the addons page for that addon.

Has anyone reported this? It’s a rather serious bug, especially after a reboot of the host.
I was facing the same behavior, Nginx would not start upon reboot, even though MariaDB seemed to work for anything else. All domains were thus unreachable.
I disabled both watchdogs and now it’s working. Should both watchdogs be disabled? Or which of the two?
Watchdogs serve a purpose too. This should be a temporary solution.