No access to path! and Integration 'whitelist_external_dirs' not found

Hi,

I have been trying to get this right for a while and no progress at all… What am I doing wrong here?

Configured two cameras and an automation that saves a short clip if motion is detected, seems to work but I get the “no access to path!” error. The clips are supposed to be written to a temp folder that I created inside the share folder with samba. In windows looks like:

\\192.168.178.30\share\temp

Maybe is not accessible because is not whitelisted? So tried this in the configuration.yaml:

  # Whitelist Folders
whitelist_external_dirs:
    - /share/temp

But then got the "Integration ‘whitelist_external_dirs’ " not found.

What can I do to get this working? The action part of the automation looks like this:

data:
  duration: 30
  filename: '/share/temp {{ entity_id }}_{{ now().strftime("%Y%m%d-%H%M%S") }}.mp4'
entity_id: camera.kamera_garten
service: camera.record

Thaks for your help!

1 Like

That’s because your indenting is missing :wink:

If you look at the docs you’ll notice that it’s supposed to be indented under homeassistant:

homeassistant:
  whitelist_external_dirs:
    - /share/temp
2 Likes

Oh well this is very embarrassing… somehow the whole:

homeassistant:
  name: Home
  latitude: 32.87336
  longitude: 117.22743
  elevation: 430
  unit_system: metric
  time_zone: America/Los_Angeles
  external_url: "https://www.example.com"
  internal_url: "http://homeassistant.local:8123"
  whitelist_external_dirs:
    - /usr/var/dumping-ground
    - /tmp

Was missing from my configuration… wonder what happened to it. :stuck_out_tongue:

That solved it, thanks for your help!