No hue rooms after upgrade to 0.39

Hi folks,

I recently upgraded HA to 0.39.
Before the upgrade i used to have a bunch of light.xxx entities that were equivalent to the rooms defined in my hue hub. These we discovered automatically not manually defined.
After the upgrade I noticed that all these hue room light entities have disappeared.
The room light entites are useful as they allow to control all lights in a room (on/off; brightness) with one control. I didnt yet see if grouping the individual lights in HA will function identically.

Is support for hue rooms deprecated in 0.39?

I upgraded to .39.1 (from .37.3) this morning and I am still seeing Hue groups.

Ok thanks. Guess either it’s something in 0.39 as opposed to 0.39.1 or something screwed up on my system

.38 notes:

Light - Hue: Fix lightgroups not syncing state

1 Like

I tried a few more things, but still no luck…

  1. I tried creating a new room in hue app, but its not picked up by HA
  2. I deleted my phue.conf file, let HA rediscover the hue bridge etc, but no rooms appearing in HA

The only other thing I can think of is to enable hue component manual rather than using discovery as apparantly this will allow to explicitly enable/disable room discovery:

allow_hue_groups (Optional): (true/false) Enable this to stop Home Assistant from importing the groups defined on the Hue bridge.

Calling the Hue API I can see my room groups:

curl http://192.168.1.38/api/username/groups

{
“2”: {
“name”: “Kitchen”,
“lights”: [
“6”
],
“type”: “Room”,
“state”: {
“all_on”: false,
“any_on”: false
},
“class”: “Kitchen”,
“action”: {
“on”: false,
“bri”: 254,
“alert”: “none”
}
},
“3”: {
“name”: “hgrp-0000000014”,
“lights”: [
“2”,
“3”,
“1”
],
“type”: “LightGroup”,
“state”: {
“all_on”: false,
“any_on”: false
},
“recycle”: false,
“action”: {
“on”: false,
“bri”: 142,
“hue”: 0,
“sat”: 0,
“effect”: “none”,
“xy”: [
0,
0
],
“ct”: 0,
“alert”: “none”,
“colormode”: “hs”
}
},
“4”: {
“name”: “hgrp-0000000006”,
“lights”: [
“2”,
“1”
],
“type”: “LightGroup”,
“state”: {
“all_on”: false,
“any_on”: false
},
“recycle”: false,
“action”: {
“on”: false,
“bri”: 142,
“alert”: “none”
}
},
“5”: {
“name”: “Hallway”,
“lights”: [
“5”,
“4”
],
“type”: “Room”,
“state”: {
“all_on”: false,
“any_on”: false
},
“class”: “Hallway”,
“action”: {
“on”: false,
“bri”: 122,
“alert”: “none”
}
},
“6”: {
“name”: “hgrp-0000000062”,
“lights”: [
“4”,
“3”,
“2”,
“5”,
“1”
],
“type”: “LightGroup”,
“state”: {
“all_on”: false,
“any_on”: false
},
“recycle”: false,
“action”: {
“on”: false,
“bri”: 142,
“hue”: 0,
“sat”: 0,
“effect”: “none”,
“xy”: [
0,
0
],
“ct”: 0,
“alert”: “none”,
“colormode”: “hs”
}
},
“7”: {
“name”: “Living Room”,
“lights”: [
“1”,
“2”,
“3”
],
“type”: “Room”,
“state”: {
“all_on”: false,
“any_on”: false
},
“class”: “Living room”,
“action”: {
“on”: false,
“bri”: 0,
“hue”: 0,
“sat”: 0,
“effect”: “none”,
“xy”: [
0,
0
],
“ct”: 0,
“alert”: “none”,
“colormode”: “hs”
}
}
}

Just reporting back that adding the hue config manually works :smiley:

light:
platform: hue
host: 192.168.1.38
allow_hue_groups: true

I have discovery turned off and have my Hue manually added. I don’t have “allow_hue_groups” in my config, though.

Thanks for the inputs. I’ll keep it manually configured going forward.