No network after power off

Hi - I run hassos on VirtualBox in Windows and it has been happy for over a year. unfortunately I did an unclean shutdown on the host (windows update) and since then the VM cannot see the network.
I get the following errors on startup

Querying the CLI shows no address

The host windows machine is happily on the network. The router is not seeing the VM’s MAC and is not allocating an IP.

I’ve had a look at the Windows Defender firewall and cannot see anything obvious blocked … but not sure what I should be looking for (Oracle Virtual Box??)

Any ideas?

Have you tried reboot host again, or/and entire VB

Thanks for getting back to me. I have restarted the VM multiple times, the VirtualBox host and the Windows host. Still no network.
I have started another VM on the VirtBox and that is also not seeing the network … but for some reason >apt update etc does work. There does apear to be an adapter with an IP address (10.0…)but it is not coming from the router.

What is really weird is that the new debian VM can perform apt update etc and I can use CURL to get a response from a webserver on the windows box …
I guess outbound connectivity is provided though the VM host in some way? I just cannot connect inbound!

Inbound connections possible :

No inbound connections possible:


Thanks, that was a huge help. My test VM was set up as NAT which explains the behaviour, but my HA VM was set up correctly … except the the interface was using WiFi not ethernet adapter. Sorted that rebooted and it works :smiley:
I think I must have disturbed the network cable so when VirtualBox restarted it only saw one adapter and used that. Unfortunately the laptop was in airplane mode :roll_eyes:
Really appreciate all the help in nudging me towards the fix - cheers!