No Roku being discovered - help

I am having a hard time getting my home assistant recognizing any of my 2 Rokus. I myself feel there is no good documentation on the home assistant website for getting this to run. All it says is to put media_player and then under that - roku. And then it should find it. Slightly frustrating for me. I check the forums here and the few threads on trying to get home assistant to recognize the roku are not helpful it seems either. Sorry for the slight rant.

Here is a copy of my configuration file with few edits for I guess privacy

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: (random number)
  longitude: (random number)
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: (random number)
  # metric for Metric, imperial for Imperial
  unit_system: imperial
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: America/Chicago

  customize:
    # Add an entry for each entity that you want to overwrite.
  
# Customization file
  customize: !include customize.yaml


# Show links to resources in log and frontend
introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

http:
  # Secrets are defined in the file secrets.yaml
  # api_password: !secret http_password
  # Uncomment this if you are using SSL/TLS, running in Docker container, etc.
  # base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

media_player: !include media-player.yaml

nest:
  client_id: (random number)
  client_secret: (random number)

google_assistant:
  project_id: (random number)
  client_id: (random number)
  access_token: (random number)
  agent_user_id: (my email)


# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# Weather prediction
sensor:
  - platform: yr

# Text to speech
tts:
  - platform: google
  
sabnzbd:
    api_key: (api key)
    host: (ip address)
    name: sab
    port: 8080
    sensors:
        - current_status
        - speed
        - queue_size
        - queue_remaining
        - disk_size
        - disk_free
        - queue_count
        - day_size
        - week_size
        - month_size
        - total_size

device_tracker:
   - platform: nmap_tracker
     hosts:
     - (ip address)
     - (ip address)
     home_interval: 10
     exclude: (ip address)

# Cloud
cloud: !include cloud.yaml
group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

Well you don’t seem to have defined it.
You need something like this:

media_player:
  - platform: roku

I have discovery: in my config file so I don’t specify roku but that is how to do it.
Also when you post code, see the note at the top of the forum so you do it properly. Very hard to help you otherwise.

(Edit: I see you have it mostly there… missed it the first time)

Could you explain more on what you mean mostly there? Is there something that I am missing?

It looks like you formatted it properly now so all good.

So I added this below to my configuration.yaml

media_player: !include media-player.yaml

Which includes these properties below and my roku is now discovered.

- platform: roku
- platform: plex

But now my automations where I have my google home speak. No longer says anything. I play one trigger and I hear the volume blip sound on the google home which means it is raising the volume, but then it doesn’t say what I want it to say and then the volume blip again goes down. Which is part of my welcome home automation.

Though if I go to the google home card and type in what I want it to say. it works.

Below is my automation file

- alias: "Welcome home Christoph"
  trigger:
    platform: state
    entity_id: device_tracker.4c74bfae057c
    from: 'not_home'
    to: 'home'
  condition:
    condition: time
    after: '18:00:00'
    before: '19:30:00'
    weekday:
      - sun
      - mon
      - tue
      - wed
      - sat
  action:
    - service: media_player.volume_set
      data_template:
        entity_id: media_player.living_room_speaker
        volume_level: 0.83
    - service: tts.google_say
      data_template: 
        message: >
          ' {{ ["Welcome home Christoph!", "Glad your back Christoph", "Good to see you again Christoph", "Good to see you, it is", "Christoph the king has returned!"] | random }}'
    - delay: '00:00:04'
    - service: media_player.volume_set
      data_template:
        entity_id: media_player.living_room_speaker
        volume_level: 0.50
      
- alias: "Good morning"
  trigger:
    platform: state
    entity_id: media_player.living_room_roku
    to: 'playing'
  action:
    service: tts.google_say
    data_template: 
      message: >
        ' {{ ["Wakey wakey, eggs and bakey!", "Rise n’ shine!", "Good morning", "Mornin', good-lookin'!", "Top o' the mornin’ to ya!", "Bad morning, it is not!"] | random }}'
      
- alias: "Sab is downloading"
  trigger:
    platform: state
    entity_id: sensor.sab_status
    to: 'Downloading'
  condition:
    condition: time
    after: '11:00:00'
    before: '23:59:00'
  action:
    service: tts.google_say
    data: 
      message: "By the way a movie or show is downloading"

So I just decided to try to figure out why my tts.google_say is no longer working. So I brought my google home mini from my living room in with my pc and re-plugged it in and restarted my home assistant service just because. But now my Google home tts.google_say automations are working but now my Roku is no longer discovered.

update:

Okay so I restarted my roku and restarted home assistant and now it’s picking up the Roku and Google home but now the my tts.google_say automations no longer work again.

So I fixed it. Before when I only had my google home I did not have to specify the entity_id for that specific home. But when my server started recognizing the roku. It seems in my automations that I have to know add the entity_id for that google home and that fixed it!