No Z-wave configuration menu in Armbian/HA

Greetings,

I am new to HA but I am familiar with linux. I have just purchased a z-wave USB stick and a few z-wave+ devices and was experimenting HA with it. I do have a spare RPI3 but I found it to be too slow, thus I am experimenting with running HA on Armbian with a Amlogic S912 tv box (8-core, 2GB RAM with 1gbit ethernet). The base linux I am using is balbes150’s armbian (https://forum.armbian.com/topic/7930-armbian-for-amlogic-s9xxx-kernel-5x/), the flavour of which is Debian Buster. After a clean-install to the SD card, I installed HA using armbian-configuration->Software->Softy, which installs HA through Docker.

It is much faster than RPI3. However, there is no z-wave sub-menu under configuration menu. I followed the advice here (https://www.home-assistant.io/docs/z-wave/control-panel/), and installed the “configurator” add-on. The configuration.yaml on both RPI3 (with z-wave submenu) and on armbian (without z-wave submenu) are identical:

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

My questions are:

  • where in RPI3 does it store the information about USB path to the ZooZ USB stick if it is not in configuration.yaml? I do recall that, during the initial setup on RPI3, I had manually specify the USB path via web-gui,
  • on armbian/S912, do I simply add the following line to configuration.yaml:
zwave:
  usb_path: /dev/ttyACM0
  device_config: !include zwave_device_config.yaml

sorry for the trivial question; it has been a long day.

regards,

The control panel isn’t displayed until you enable the Z-Wave integration. That is done either via configuration.yaml, as you’ve shown in your example, or in the UI via the Integrations page (Control Panel -> Integrations). The choice of which method is up to you. In either case, I would recommend using the usb path /dev/serial/by-id/usb-0658_0200-if00 if it exists. If you use configuration.yaml, make sure you also create a network key in case you need to do secure inclusions later. The UI will create a key for you.

If you haven’t already, I would start with reading the Getting Started section of the z-wave docs, not with the control panel docs.

where in RPI3 does it store the information about USB path to the ZooZ USB stick if it is not in configuration.yaml?

In the file .storage/core.config_entries.

Thanks for the prompt reply. And I apologize for the lack of clarity in my original post. It was late at night and I’ve been working on the problem for way too long.

My point was that, there is no access to z-wave integration page under Control Panel->Integrations on Armbian. On RPI3 (default image) it is there, and I could enable it and specify the USB path for the USB hub.

On Armbian the z-wave integration sub-menu is simply missing from Control Panel->Integrations. That’s why I was asking about modifying configurations.yaml directly.

Will perform further testing tonight,

regards,

Is Z-Wave showing up in the Integrations page? Check the home assistant log and make sure the zwave python module didn’t fail to install.

no it is not. There is no z-wave sub-menu under the Integrations page.

If you are able (I don’t have access to my HA system from work), how do I go about check if the python model is installed properly?

no it is not. There is no z-wave sub-menu under the Integrations page.

If Z-Wave is installed, you should see something like this in the Integrations page:


You don’t see the Z-Wave entry at all? That would seem to indicate it didn’t get setup properly. Are there any z-wave entities available? How have you setup z-wave on the Armbian, using the UI or configuration.yaml?

As long as the integration is installed, the control panel should show up, even if the z-wave network fails to start. I would check the HA log file and make sure there are no unexpected errors.

I also just noticed you said HA was installed via Docker. If that’s the case, and it is using the official Docker image, than the zwave module is pre-installed, so nothing to do in that case. I would still check the log file for any errors.

hi, I started from scratch (installing Armbian/HD again) but ended up in the same place. Here are the screenshots.

From RPI3, under configuration:

Note the last entity is “z-wave”.

Now, on a fresh-install Armbian/HA (via docker):


Note the last entity is “Users”, no Z-wave sub-menu.

I’ll modify configurations.yaml and report back as I go.

But don’t you have to “turn on” zwave in order for it to show up?

What happens when you hit the plus button on integrations and point it to your zwave controller?

here is the system log. Looks like a RPI4-64 docker image was used in armbian:

System log
20-01-09 00:04:37 INFO (MainThread) [__main__] Initialize Hass.io setup
20-01-09 00:04:37 INFO (MainThread) [hassio.docker.network] Can't find Hass.io network, create new network
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Home Assistant configuration folder /data/homeassistant
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io SSL/TLS folder /data/ssl
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on data folder /data/addons/data
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on local repository folder /data/addons/local
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io Add-on git repositories folder /data/addons/git
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io temp folder /data/tmp
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io backup folder /data/backup
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io share folder /data/share
20-01-09 00:04:38 INFO (MainThread) [hassio.bootstrap] Create Hass.io DNS folder /data/dns
20-01-09 00:04:38 WARNING (MainThread) [hassio.utils.dt] Can't fetch freegeoip data: Cannot connect to host ip-api.com:80 ssl:None [Address not available]
20-01-09 00:04:38 INFO (SyncWorker_0) [hassio.docker.supervisor] Attach to Supervisor homeassistant/aarch64-hassio-supervisor with version 193
20-01-09 00:04:38 INFO (SyncWorker_0) [hassio.docker.supervisor] Connect Supervisor to Hass.io Network
20-01-09 00:04:38 INFO (MainThread) [__main__] Setup HassIO
20-01-09 00:04:38 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.systemd1 - /org/freedesktop/systemd1
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.hostname1 - /org/freedesktop/hostname1
20-01-09 00:04:39 WARNING (MainThread) [hassio.dbus.rauc] Host has no rauc support. OTA updates have been disabled.
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Connect to dbus: org.freedesktop.NetworkManager - /org/freedesktop/NetworkManager/DnsManager
20-01-09 00:04:39 INFO (MainThread) [hassio.host.info] Update local host information
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/hostname1
20-01-09 00:04:39 INFO (MainThread) [hassio.host.services] Update service information
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ListUnits on /org/freedesktop/systemd1
20-01-09 00:04:39 INFO (MainThread) [hassio.host.network] Update local network DNS information
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.DBus.Properties.GetAll on /org/freedesktop/NetworkManager/DnsManager
20-01-09 00:04:39 INFO (MainThread) [hassio.host.apparmor] Load AppArmor Profiles: {'hassio-supervisor'}
20-01-09 00:04:39 INFO (MainThread) [hassio.host.services] Reload local service hassio-apparmor.service
20-01-09 00:04:39 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.ReloadOrRestartUnit on /org/freedesktop/systemd1
20-01-09 00:04:39 INFO (MainThread) [hassio.dns] No CoreDNS plugin Docker image homeassistant/aarch64-hassio-dns found.
20-01-09 00:04:39 INFO (MainThread) [hassio.dns] Setup CoreDNS plugin
20-01-09 00:04:39 INFO (MainThread) [hassio.updater] Fetch update data from https://version.home-assistant.io/stable.json
20-01-09 00:04:40 INFO (SyncWorker_2) [hassio.docker.interface] Pull image homeassistant/aarch64-hassio-dns tag 1.
20-01-09 00:05:01 INFO (MainThread) [hassio.dns] CoreDNS plugin now installed
20-01-09 00:05:01 INFO (MainThread) [hassio.dns] Update resolv from Supervisor
20-01-09 00:05:01 INFO (MainThread) [hassio.dns] Start CoreDNS plugin
20-01-09 00:05:01 INFO (MainThread) [hassio.misc.forwarder] Start DNS port forwarding to 172.30.32.3
20-01-09 00:05:03 INFO (SyncWorker_0) [hassio.docker.dns] Start DNS homeassistant/aarch64-hassio-dns with version 1
20-01-09 00:05:03 INFO (MainThread) [hassio.homeassistant] No Home Assistant Docker image homeassistant/raspberrypi4-64-homeassistant found.
20-01-09 00:05:03 INFO (MainThread) [hassio.homeassistant] Setup HomeAssistant landingpage
20-01-09 00:05:03 INFO (SyncWorker_1) [hassio.docker.interface] Pull image homeassistant/raspberrypi4-64-homeassistant tag landingpage.
20-01-09 00:05:17 INFO (MainThread) [hassio.store.git] Clone add-on https://github.com/hassio-addons/repository repository
20-01-09 00:05:17 INFO (MainThread) [hassio.store.git] Clone add-on https://github.com/home-assistant/hassio-addons repository
20-01-09 00:05:20 INFO (MainThread) [hassio.store] Load add-ons from store: 62 all - 62 new - 0 remove
20-01-09 00:05:20 INFO (MainThread) [hassio.addons] Found 0 installed add-ons
20-01-09 00:05:20 INFO (MainThread) [hassio.snapshots] Found 0 snapshot files
20-01-09 00:05:20 INFO (MainThread) [hassio.discovery] Load 0 messages
20-01-09 00:05:20 INFO (MainThread) [hassio.ingress] Load 0 ingress session
20-01-09 00:05:20 INFO (MainThread) [hassio.secrets] Load Home Assistant secrets: 0
20-01-09 00:05:20 INFO (MainThread) [__main__] Run Hass.io
20-01-09 00:05:20 INFO (MainThread) [hassio.api] Start API on 172.30.32.2
20-01-09 00:05:20 INFO (MainThread) [hassio.addons] Phase 'initialize' start 0 add-ons
20-01-09 00:05:20 INFO (MainThread) [hassio.addons] Phase 'system' start 0 add-ons
20-01-09 00:05:20 INFO (MainThread) [hassio.addons] Phase 'services' start 0 add-ons
20-01-09 00:05:25 INFO (SyncWorker_9) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi4-64-homeassistant with version landingpage
20-01-09 00:05:30 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-01-09 00:05:30 INFO (MainThread) [hassio.addons] Phase 'application' start 0 add-ons
20-01-09 00:05:30 INFO (MainThread) [hassio.tasks] All core tasks are scheduled
20-01-09 00:05:30 INFO (MainThread) [hassio.core] Hass.io is up and running
20-01-09 00:05:30 INFO (MainThread) [hassio.homeassistant] Setup Home Assistant
20-01-09 00:05:30 INFO (SyncWorker_3) [hassio.docker.interface] Update image homeassistant/raspberrypi4-64-homeassistant:landingpage to homeassistant/raspberrypi4-64-homeassistant:0.103.6
20-01-09 00:05:30 INFO (SyncWorker_3) [hassio.docker.interface] Pull image homeassistant/raspberrypi4-64-homeassistant tag 0.103.6.
20-01-09 00:11:41 INFO (SyncWorker_3) [hassio.docker.interface] Stop homeassistant application
20-01-09 00:11:53 INFO (SyncWorker_3) [hassio.docker.interface] Clean homeassistant application
20-01-09 00:11:53 INFO (MainThread) [hassio.homeassistant] Home Assistant docker now installed
20-01-09 00:11:53 INFO (MainThread) [hassio.homeassistant] Start Home Assistant
20-01-09 00:11:54 INFO (SyncWorker_13) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi4-64-homeassistant with version 0.103.6
20-01-09 00:12:24 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-01-09 00:12:24 INFO (SyncWorker_17) [hassio.docker.interface] Cleanup images: ['homeassistant/raspberrypi4-64-homeassistant:landingpage']
20-01-09 00:45:52 INFO (MainThread) [hassio.addons] Create Home Assistant add-on data folder /data/addons/data/core_configurator
20-01-09 00:45:52 INFO (SyncWorker_35) [hassio.docker.interface] Pull image homeassistant/aarch64-addon-configurator tag 4.2.
20-01-09 00:46:54 INFO (MainThread) [hassio.addons] Add-on 'core_configurator' successfully installed
20-01-09 01:02:38 INFO (MainThread) [hassio.addons] Create Home Assistant add-on data folder /data/addons/data/a0d7b954_logviewer
20-01-09 01:02:38 INFO (SyncWorker_39) [hassio.docker.interface] Pull image hassioaddons/log-viewer-aarch64 tag 0.6.4.
20-01-09 01:03:04 INFO (MainThread) [hassio.addons] Add-on 'a0d7b954_logviewer' successfully installed
20-01-09 01:03:17 INFO (SyncWorker_22) [hassio.docker.addon] Start Docker add-on hassioaddons/log-viewer-aarch64 with version 0.6.4
20-01-09 01:03:19 ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:1337 ssl:None [Connection refused]
20-01-09 01:03:23 INFO (MainThread) [hassio.api.security] /host/info access from a0d7b954_logviewer
20-01-09 01:03:24 ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host 172.30.33.0:1337 ssl:None [Connection refused]
20-01-09 01:03:30 INFO (SyncWorker_2) [hassio.docker.interface] Stop addon_a0d7b954_logviewer application
20-01-09 01:03:33 INFO (SyncWorker_2) [hassio.docker.interface] Clean addon_a0d7b954_logviewer application
20-01-09 01:03:33 INFO (SyncWorker_2) [hassio.docker.interface] Remove image hassioaddons/log-viewer-aarch64 with latest and 0.6.4

arrahhh… I hate myself.

you are right. I have to enable “Advanced Mode” and then “turn on”" z-wave.

Thank you! now, I am going to connect my z-wave+ switches,

regards,

That’s what @freshcoast was saying all along. :smiley: