No zwave devices after clean install and restored backup?

Hi All,

Did a clean HassOS install on my intel nuc yesterday. (I was running a diy docker setup that gave me issues). Then, restored the configuration from a snapshot.

I am using a aeotec zwave stick and it was working well before the reinstall. But, after importing the snapshot, none of the devices are available and I have no idea how to debug.

The configuration was using the zwave component (on home assistant 0.115), but in the newest version I understand the open zwave add-on is used.

The thing is:

  • all zwave devices present in the snapshot are now “unavailable” in the entities list.
  • open zwave add-on remote client shows nothing in the node list, but the logs show a lot of warnings:
[20201218 12:46:18.116 CET] [ozw.library] [warning]: Warning - Node: 0 WARNING: Out of frame flow! (0x54).  Sending NAK. 

How can I debug this? I see no obvious errors indicating where things are going wrong. Any help is greatly appreciated!

If you’ve changed from the old Zwave component to the OpenZwave add-on, have you removed the old component and added the Mosquitto MQTT add-on, which is required for the OpenZwave beta?

1 Like

Yes, I am using the MQTT add-on succesfully for other mqtt enabled sensors and switches, so that is working fine. I am guessing there is something wrong between open z-wave add-on and the usb stick since I do not see anything in the node-list. But, I am not entirely sure if that’s it though.

But, as I understand it, with the open z-wave add-on, I would not expect to see any zwave.xxx devices in the entity list anymore, right? Since HA is now communicating to those devices with mqtt?

No - the Zwave network is held in the controller, so it should be being read out of the controller by the ozwdaemon and passed as MQTT messages to HA (as I understand it). What do you see in the ozwadmin screen?

BTW, on startup, the reading and setting up of the Zwave network into HA can take several minutes to complete.

Assuming this is indeed the ozwadmin screen, this is what I see. I notice the ozwlog tab at the bottom of the screen does show stuff, but not very readable, I will go hunt for the whole file…

Additionally, the documentation for the add-on specifically states the device path (/dev/serial/by-id/usb-0658_0200-if00) should be in quotes, but if I do enter that, those get removed when saving the configuration?

Just guessing here - but could that “checksum incorrect” message indicate that you are using an incorrect network key?

The missing quotes are OK - I don’t have them in my configuration file either.

Also, doing a search on “out of frame flow” in the forum may give you something to work with…

I am not using a network key, nor was I in the previous installation. In all my previous setups, the usb stick was always node 1. Am I right in assuming that Node 0 would refer to the open z-wave controller?

No - it should be node 1, as in:

thanks, I have started from scratch again and as long as I don’t restore the 0.115 backup, it seems to work fine. As soon as I restore the snapshot, it breaks. Even if I remove the zwave component manually from the yamls.

Well, there is something about a fresh install also, so I’ll get back to adding all devices and automations :smiley: Good that I have a few days off haha