Node Red cannot connect

Hello,
i am a little desperated because i cannot get Node Red to work.

My Prerequistes:
Hass IO an a Rasperyy PI in a local Network
DuckDNS only for external stateschange (no config change necessary)
i try to access NodeRed from internal network

installed Node Red:

  • give Credential and passwords
  • set both ssl to true
  • can LockIn and play with Nodes^^ (in https://xx.xx.xx.xx:1880)
  • i cannot change any state in NodeRed --> LogFile: Cannot get Connection to HomeAssistant xx.xx.xx.xx:8123 (=Password depraced)
  • i checked the admin password ten times, its correct.

HomeAssistant is running without any Problems on this IP: https://xx.xx.xx.xx:8123

What did i miss?

Thx in Advance
Wiesl

If you’re using duckdns and SSL you can’t connect to the IP address using SSL. It will fail. Use the duckdns name

Secondly there is a bug with the config of the HA nodes. You have to deploy another flow before it will connect. Anything. I usually tell people to stick an inject node and a debug node and deploy. Then try to connect to HA.

ok i try to but no suceess:
here my properties:


and here the log without error before entering: https://pastebin.com/MSajC9zu
than a debug node which is functional:
than my HomeAssistant via DuckDNS:
than i set my srv to toggle my light: service%20node2

than nothing happens beside following log spamming line:

what did i do wrong? i am clueless, which mistake i am doing over and over!!

Thx in advance
Wiesl

Do you actually have the api_password in your home assistant config?

Are you connecting to the correct part?

Does your router support hairpin Nat or nat reflection?

This is another reason I use a reverse proxy. I have full local access to my ha within my network, and SSL on remote connections

yes, API Password is set in the configuration.yaml
yes, Port is the right one i need to connect to the HAss.io System

than here is a problem, i donnot know anything about hairpin nat or nat reflection.
I simply forwarded the port used by Hass.io and Duck.dns to get access from Outside.

is there any possibility to get Node Red running?

The simple test is:

From your internal network, can you hit your duckdns address and get to your Home Assistant instance? If so, your NAT reflection/Hairpin NAT is working fine.

I don’t see why it’s not working for you.

Is this a Problem?
I cannot get to my HA via my DuckDNS Adress while i am in the same network, or in the same WLAN.
If i deactivate WLAN i get immidiate access. (Error Code. “ERR_Connection_Reset”)

Should i try to deactivate my DYNDNS and only activate it when i finish configuration atm?
This is for sure not the ideal solution, after getting DuckDNS running after many hours^^

This simply means your Hairpin NAT/NAT reflection doesn’t work. Your router may not support such a feature.

Personally, I use a reverse proxy instead of an automated duckdns/letsencrypt method. I can access my instance locally, without the hassle of SSL/certificate errors, yet I can still use an encrypted connection via my reverse proxy when I am not on the network.

This isn’t just for configuration. Node-red needs to be able to talk to your HA install all the time, otherwise it doesn’t do anything since everything has to go over the API.

Is there any tutorial on using a reverse proxy for using in HA? especially Hass.io?

Because i like to check some states from outside, one reason to use Home Assistant for me!

I don’t know. From a basic Google search I see several forum posts discussing a configuration. Apparently there are some add-ons for doing so.

2nd Possibility disable all the https / dynDNS story and get access over TOR?
like: TOR,
do you think its worth the effort and i should change my complete Configuration?

I have never used the TOR method, and really have no reason to. I say, try it and see if it works for you.