Node-red-contrib-home-assistant-websocket


#152

I’m running 0.84.6


#153

Also to get more debug information for the logs you can start node-red with DEBUG=home-assistant* node-red.


#154

ignore. No idea how I fixed it, but it is working now.

In the process of moving HA to a linux box running on my network and installing NR on a rPi. HA is working fine, and NR is up and running. I installed the Node-red-contrib-home-assistant-websocket, and am attempting to connect to HA with no luck. I enter the HA instance ip address and put in the long lived access token, but I get an error message of “can’t get entities”. I’m running the latest version of NR on latest version of raspbian (no docker or anything). I have the v10.15.0 of node.js. I am running HassOs on the Linux box (Mint), and version 0.84.6 of HA.

One thing that might be going on is that Hass has the NR addon installed. I tried stopping it, and connecting the rPi but that didn’t work. Should I uninstall the addon? Or is there some other issue?


#155

Hi all. New here, had a good read but…

I’m struggling to get the call service node to send the data I am inputting into it to home assistant.

To clarify the system is working as it should afaik. I just can’t get the node to output the data.

I’m trying to get it to call climate.set_temperature with a temperature. I’m sending the required temperature to the node from a thermostat node. The msg.payload is just a number

The debug from the thermostat is:

13/01/2019, 23:25:53node: Living room temperature set point.

target : msg : Object

object

topic: “target”

payload: 18.29

qos: 0

retain: false

_msgid: “f242126d.2f46c”

The debug from the call service node is:

13/01/2019, 23:25:54node: 38f8212b.381b56

target : msg : Object

object

topic: “target”

payload: object

domain: “climate”

service: “set_temperature”

data: object

entity_id: “climate.danfoss_popp_radiator_thermostat_heating_1”

temperature: “”

qos: 0

retain: false

_msgid: “f242126d.2f46c”

So, in short. How do I get the 18.29 from the thermostat between the “” of the call service output?

Sorry if this is simple and I’m sure it’s very obvious but I’m struggling.

Regards.


#156

Need to set the temperature in the data field

[{"id":"ac0146ab.de3628","type":"api-call-service","z":"6edf92e.d52b66c","name":"","server":"8d00ebbc.99a928","service_domain":"climate","service":"set_temperature","data":"{\"entity_id\":\"climate.danfoss_popp_radiator_thermostat_heating_1\",\"temperature\":\"{{payload}}\"}","render_data":true,"mergecontext":"","output_location":"payload","output_location_type":"msg","x":742,"y":448,"wires":[[]]}]

#157

Thanks. It works now. I was using {“temperature”:"{{msg.payload}}"}

I also noticed I was using an old version of the node.


#158

Not sure what I did but my debug in Node-Red is now filled with

"Home assistant connection failed with error: Connection to home assistant could not be established with config: https://notmydomain.duckdns.org:8123 <password redacted>"

for each variant of the URL I tried… ie 4-5 messages keep spamming in the debug even if I remove the connection, uninstall the contrib etc… anyone know how I can remove it?


#159

This error message isn’t from this fork it’s from one of the other two make sure you own have only one installed.


#160

If you have command line access:

$ cd ~/.node-red
$ npm uninstall node-red-contrib-home-assistant
$ npm uninstall node-red-contrib-home-assistant-llat
# restart node-red

#161

New Release v0.6.0

New Features

  • The call-service node autocomplete for entity_id now handles multiple entities

  • The properties field of a trigger-state node now has autocomplete

  • Added a new comparator, ‘in group’, to the get-entities node

  • Get-history node can use a relative time string for its date fields

Added

  • A more verbose error message for the autocomplete error when the server config hasn’t been deployed

  • More informative error message for the call-service node when there’s an API error

Changed

  • Change the connect timeout for hass.io users so it doesn’t bombard the proxy when attempting to connect. (#76)

Fixed

  • HomeAssistant object updated before firing state_change event (#74)

  • Fixed HTTP API so it returns an empty string and not the response object when res.data is empty.

(#78)


#162

Ooooh, “in group”, thank you very much!


#163

I’m struggling with relative time for the get history node. Even entering the example of “20 minutes” gives me the following output.

"value" must be a number of milliseconds or valid date string


#164

Fix released in v0.6.1


#165

Thanks. It’s working well. That’s a great change which means I can remove function nodes that I was using calculate the time 60 seconds ago :slight_smile:


#166

Looks like the server-state-changed node flag Output Initially / On Deploy doesn’t trigger when only doing a partial Deploy like Modified Flows or Modified Nodes even when that node is within a modified flow or is a modified node.


#167

Yes. I haven’t had a chance to look into it but you can follow its progress below.


#168

Hi, curious question, is this only to be used with hassio? I’m trying to set this up with duckdns and https and I’m getting a message that says invalid format of base URL: Undefined. is anyone else experiencing this?


#169

There’s a hassio addon that allows this to work with hassio but this is a stand alone package that works with Node-RED. Sounds like you don’t have anything in the Base URL field.


#170

New Release v0.7.0

Bug Fixes

  • Added a check for valid server (66d8daf)

  • Fix for nodes to trigger on deploy (8205236), closes #80

  • trigger-state: Fix to show the correct properties for constraints (62e22fa)

Features

  • current-state: Added customizable outputs for state and entity (0a51c5d)

  • event-state: Added “Only output on state change” (0707d72)

  • wait-until: New ‘Wait Until’ Node (6717972), closes #82


Buy me a coffee For those that enjoy my work.


#171

event-state: Added “Only output on state change” (0707d72)

does that eliminate the need for an RBE node after the event node?