Node-red-contrib-smartmeter installation error

Hi,

I just tried to install node-red-contrib-smartmeter but I got these errors and maybe somebody is able to help. I’m running HA 0.99.3 on HassOS 3.4.

-----------------------------------------------------------
2019-10-03T18:31:40.831Z installieren : node-red-contrib-smartmeter 0.2.1

2019-10-03T18:31:41.869Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production [email protected]
2019-10-03T18:32:01.041Z [out] 
2019-10-03T18:32:01.041Z [out] > [email protected] install /config/node-red/node_modules/serialport
2019-10-03T18:32:01.041Z [out] > prebuild-install || node-gyp rebuild
2019-10-03T18:32:01.041Z [out] 
2019-10-03T18:32:02.728Z [err] prebuild-install
2019-10-03T18:32:02.729Z [err]  
2019-10-03T18:32:02.730Z [err] WARN
2019-10-03T18:32:02.730Z [err]  
2019-10-03T18:32:02.730Z [err] install
2019-10-03T18:32:02.730Z [err]  No prebuilt binaries found (target=10.16.3 runtime=node arch=arm platform=linux)
2019-10-03T18:32:04.392Z [err] gyp
2019-10-03T18:32:04.392Z [err]  
2019-10-03T18:32:04.393Z [err] ERR! 
2019-10-03T18:32:04.393Z [err] build error 
2019-10-03T18:32:04.394Z [err] gyp
2019-10-03T18:32:04.394Z [err]  ERR!
2019-10-03T18:32:04.394Z [err]  stack
2019-10-03T18:32:04.394Z [err]  Error: not found: make
2019-10-03T18:32:04.394Z [err] gyp
2019-10-03T18:32:04.395Z [err]  ERR! 
2019-10-03T18:32:04.395Z [err] stack     at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)
2019-10-03T18:32:04.395Z [err] gyp
2019-10-03T18:32:04.395Z [err]  ERR!
2019-10-03T18:32:04.395Z [err]  stack
2019-10-03T18:32:04.395Z [err]      at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)
2019-10-03T18:32:04.395Z [err] gyp
2019-10-03T18:32:04.395Z [err]  ERR! 
2019-10-03T18:32:04.395Z [err] stack     at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)
2019-10-03T18:32:04.395Z [err] gyp
2019-10-03T18:32:04.395Z [err]  ERR!
2019-10-03T18:32:04.395Z [err]  stack
2019-10-03T18:32:04.395Z [err]      at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16
2019-10-03T18:32:04.395Z [err] gyp
2019-10-03T18:32:04.395Z [err]  ERR!
2019-10-03T18:32:04.396Z [err]  stack
2019-10-03T18:32:04.396Z [err]      at /usr/lib/node_modules/npm/node_modules/isexe/index.js:42:5
2019-10-03T18:32:04.396Z [err] gyp 
2019-10-03T18:32:04.396Z [err] ERR! 
2019-10-03T18:32:04.396Z [err] stack     at /usr/lib/node_modules/npm/node_modules/isexe/mode.js:8:5
2019-10-03T18:32:04.396Z [err] gyp 
2019-10-03T18:32:04.396Z [err] ERR! 
2019-10-03T18:32:04.396Z [err] stack     at FSReqWrap.oncomplete (fs.js:153:21)
2019-10-03T18:32:04.397Z [err] gyp
2019-10-03T18:32:04.397Z [err]  ERR! 
2019-10-03T18:32:04.397Z [err] System Linux 4.19.67-v7l
2019-10-03T18:32:04.397Z [err] gyp
2019-10-03T18:32:04.397Z [err]  ERR! 
2019-10-03T18:32:04.397Z [err] command
2019-10-03T18:32:04.398Z [err]  "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
2019-10-03T18:32:04.398Z [err] gyp 
2019-10-03T18:32:04.398Z [err] ERR! 
2019-10-03T18:32:04.398Z [err] cwd /config/node-red/node_modules/serialport
2019-10-03T18:32:04.398Z [err] gyp
2019-10-03T18:32:04.398Z [err]  ERR! 
2019-10-03T18:32:04.398Z [err] node -v
2019-10-03T18:32:04.398Z [err]  v10.16.3
2019-10-03T18:32:04.398Z [err] gyp
2019-10-03T18:32:04.398Z [err]  ERR!
2019-10-03T18:32:04.398Z [err]  node-gyp -v
2019-10-03T18:32:04.398Z [err]  v3.8.0
2019-10-03T18:32:04.398Z [err] gyp 
2019-10-03T18:32:04.399Z [err] ERR! 
2019-10-03T18:32:04.399Z [err] not ok 
2019-10-03T18:32:05.279Z [err] npm
2019-10-03T18:32:05.280Z [err]  
2019-10-03T18:32:05.280Z [err] ERR!
2019-10-03T18:32:05.280Z [err]  
2019-10-03T18:32:05.281Z [err] code
2019-10-03T18:32:05.281Z [err]  ELIFECYCLE
2019-10-03T18:32:05.281Z [err] npm
2019-10-03T18:32:05.282Z [err]  
2019-10-03T18:32:05.282Z [err] ERR!
2019-10-03T18:32:05.282Z [err]  
2019-10-03T18:32:05.282Z [err] errno
2019-10-03T18:32:05.282Z [err]  1
2019-10-03T18:32:05.285Z [err] npm
2019-10-03T18:32:05.286Z [err]  
2019-10-03T18:32:05.286Z [err] ERR!
2019-10-03T18:32:05.286Z [err]  [email protected] install: `prebuild-install || node-gyp rebuild`
2019-10-03T18:32:05.286Z [err] npm
2019-10-03T18:32:05.287Z [err]  
2019-10-03T18:32:05.287Z [err] ERR!
2019-10-03T18:32:05.287Z [err]  Exit status 1
2019-10-03T18:32:05.287Z [err] npm
2019-10-03T18:32:05.288Z [err]  
2019-10-03T18:32:05.288Z [err] ERR!
2019-10-03T18:32:05.288Z [err]  
2019-10-03T18:32:05.288Z [err] npm
2019-10-03T18:32:05.288Z [err]  
2019-10-03T18:32:05.288Z [err] ERR!
2019-10-03T18:32:05.289Z [err]  Failed at the [email protected] install script.
2019-10-03T18:32:05.289Z [err] npm
2019-10-03T18:32:05.289Z [err]  
2019-10-03T18:32:05.289Z [err] ERR!
2019-10-03T18:32:05.289Z [err]  This is probably not a problem with npm. There is likely additional logging output above.
2019-10-03T18:32:05.428Z [err] 
2019-10-03T18:32:05.429Z [err] npm
2019-10-03T18:32:05.430Z [err]  
2019-10-03T18:32:05.430Z [err] ERR!
2019-10-03T18:32:05.431Z [err]  A complete log of this run can be found in:
2019-10-03T18:32:05.431Z [err] npm
2019-10-03T18:32:05.432Z [err]  
2019-10-03T18:32:05.432Z [err] ERR!
2019-10-03T18:32:05.433Z [err]      /root/.npm/_logs/2019-10-03T18_32_05_337Z-debug.log
2019-10-03T18:32:05.464Z rc=1

Best,
Michael

Same here. Did you already solved the problem?