Node-RED vs HA 0.88.1

Hi,
this is my first topic here so I hope I wouldn’t do anything wrong. I just finished updating my HA from v0.82 to 0.88.1 and everything seems to work fine until I checked my Node-RED instance. I’m using QNAP and set both HA and Node-RED with dockers. Unfortunately node-red-contrib-home-assistant-websocket v0.7.1 is unable to connect to HA. Inside HA logs I can see error occurred every 2s which is:

Sat Feb 23 2019 09:37:44 GMT+0100 (CET)

Error handling request
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py”, line 275, in data_received
messages, upgraded, tail = self._request_parser.feed_data(data)
File “aiohttp_http_parser.pyx”, line 523, in aiohttp._http_parser.HttpParser.feed_data
aiohttp.http_exceptions.BadStatusLine: invalid HTTP method

Did anyone else experience this kind of problems? I’d like to mention that after I stopped v0.88.1 and start again v0.82 everything is working fine.

For HA I used this image: homeassistant/raspberrypi3-homeassistant:0.88.1
For NR I used this one: nodered/node-red-docker:rpi-v8

Mine is working fine after upgrading yesterday. What version of node red are you using? I’m on 0.20.0-beta.3

Thanks for reply !

I’m currently using 0.19.5. But for me it looks like HA issue, not node-red.
Besides I can’t even see your version inside ContainerStation at QNAP.

try regenerating a long lived token and try using it

Until today I was using legacy authentication. But as you suggested I generate token and still… same error :frowning: