Nodered - nbrowser

I have installed nbrowser in the nodered addon using the “manage palette” menu, there were no errors that I noticed during installation, however when I inject a url into nbrowser I get the following error:

7 May 03:56:54 - [red] Uncaught Exception:
7 May 03:56:54 - [error] Error: spawn /config/node-red/node_modules/electron/dist/electron ENOENT
    at Process.ChildProcess._handle.onexit (node:internal/child_process:283:19)
    at onErrorNT (node:internal/child_process:478:16)
    at processTicksAndRejections (node:internal/process/task_queues:83:21)
[03:56:54] INFO: Starting Node-RED...
> start
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"

Any suggestions on the cause / fix for this ? - It looks like it is unable to startup electron ?

From the page you linked

Note: You can install nbrowser using Node-RED’s
Manage Palette → Install option; however, the current version requires that you restart the Node-RED server.

Thanks, yes I have restarted several times :slight_smile:

I also tried removing nodered and it’s folder, re-installing and then installing nbrowser from the command line:npm install node-red-contrib-nbrowser and that succeeded with no errors.

needs a display manager apparently, so I added:




Xvfb -ac -screen scrn 1280x2000x24 :9.0 &
export DISPLAY=:9.0

But still exactly the same error.

Did you manage to solve the issue? I have the same problem. I need to login to Ziggo and that fails with the standard http request node. Tried nbrowser and also but that also fails in need for chrome.

Hi, no I spent a LOT of time trying to get it to work over a couple of days, I don’t think it can be done.

What I am now using instead is appDaemon and Selenium, and that works great.