NodeRed stuck on "loading plugins"

Hi, I’ve been having a problem that I hope someone here can help me to figure it out…

Since last night, my nodered installation on HASSIO keeps getting stuck on the loading plugins splash screen:

I didnt install anything or changed anything on my HASS installation… I tried from different clients (1 laptop and 1 pc), rebooted HASS and even unplugged the Raspberry Pi for a couple of minutes, but the behavior is the same…

My NodeRed log is:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] executing... 
 Add-on: Node-RED
 Flow-based programming for the Internet of Things
 Add-on version: 9.0.0
 You are running the latest version of this add-on.
 System: Home Assistant OS 5.13  (aarch64 / raspberrypi4-64)
 Home Assistant Core: 2021.4.6
 Home Assistant Supervisor: 2021.04.1
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[cont-init.d] exited 0.
[cont-init.d] executing... 
[13:39:39] INFO: Password is NOT in the Have I Been Pwned database! Nice!
[13:39:41] INFO: Password is NOT in the Have I Been Pwned database! Nice!
patching file nodes/ui_base.html
Hunk #1 succeeded at 1160 (offset 629 lines).
[13:39:41] WARNING: 
[13:39:41] WARNING: The dark_mode option has been deprecated and will be
[13:39:41] WARNING: removed in a future version. Please use the theme
[13:39:41] WARNING: option instead.
[13:39:41] WARNING: 
audited 168 packages in 8.388s
16 packages are looking for funding
  run `npm fund` for details
found 0 vulnerabilities
[cont-init.d] exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[13:39:56] INFO: Starting Node-RED...
> addon-node-red@ start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"
21 Apr 13:40:01 - [info] 
Welcome to Node-RED
21 Apr 13:40:01 - [info] Node-RED version: v1.3.3
21 Apr 13:40:01 - [info] Node.js  version: v14.16.1
21 Apr 13:40:01 - [info] Linux 5.4.83-v8 arm64 LE
21 Apr 13:40:02 - [info] Loading palette nodes
21 Apr 13:40:13 - [info] Dashboard version 2.28.2 started at /endpoint/ui
/bin/sh: /opt/node_modules/node-red-node-pi-gpio/ not found
21 Apr 13:40:15 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
21 Apr 13:40:15 - [info] Settings file  : /etc/node-red/config.js
21 Apr 13:40:15 - [info] Context store  : 'default' [module=memory]
21 Apr 13:40:15 - [info] User directory : /config/node-red/
21 Apr 13:40:15 - [warn] Projects disabled : editorTheme.projects.enabled=false
21 Apr 13:40:15 - [info] Flows file     : /config/node-red/flows.json
21 Apr 13:40:15 - [info] Server now running at
[13:40:15] INFO: Starting NGinx...
21 Apr 13:40:16 - [info] Starting flows
21 Apr 13:40:21 - [info] [cronplus:2c9c933a.42a7dc] createTask - index: 0, static: true, opt: {"name":"schedule1","topic":"schedule1","payloadType":"default","payload":"","expressionType":"cron","expression":"0 59 23 L * * *","location":"","offset":"0","solarType":"all","solarEvents":"sunrise,sunset"}
21 Apr 13:40:22 - [info] Started flows
21 Apr 13:40:22 - [info] [server:Home Assistant] Connecting to http://supervisor/core
21 Apr 13:40:22 - [info] [mqtt-broker:MQTT HA] Connected to broker: nodered@mqtt://
21 Apr 13:40:23 - [info] [server:Home Assistant] Connected to http://supervisor/core

Someone can guide me to what to check?

Thanks in advance!

1 Like

Any error messages in the browser’s developer console?

The console throws these errors:

Try clearing the browser’s cache.

Thanks for the reply…

After clearing the browser’s cache the error still persists…

Hi! I have the same problem to. I’m considering to reinstall node red and restore the flows, but any other resolution it could be appreciated.

Today I installed the red node in 2 different raspberrys (one PI · and another PI4) and in neither of the two it goes beyond the “loading plugins” window. Any ideas? I already cleaned the chache of both raspberrry

Can you guys post the add-on logs? @Pablo2k @Pucho586

Just a heads up: Tried to access NodeRed on my cellphone (Edge browser) and it loaded ok… Tried to load on my Desktop on different browser (Chrome for Windows) and also loaded ok… The browser that has been having the “loading plugins” issue is Edge for Windows… even after full cache wipe it still cannot access NodeRed… don’t know if it has to do with an update or something like that, as I haven’t changed anything on Home Assistant or Node Red side.

Good afternoon! Where do I get this data from? I did not install anything other than the NODE-RED. Accessing externally (from the windows Chrome to the ip makes the load correct and opens the NODE-RED, but from the browser of the 2 raspberrys (3 and 4) with completely new installations no I can access.

Hi @mbonani. Im looking the logs… and nothing weird appears. I always use chrome as a browser… I have deleting all the cookies and cache of the browser and nothing… but… if I open another instance of chrome, but with an “unknown” session… Node Red load up likes magic… that’s weird ah?

Apparently fixed. He was trying to run NODE-RED from Raspbian’s Chromiun and got stuck in LOADIN PLUGINS. Install firefox and it works

I don’t think is fixed… I’ve been having the same behavior for three days… It started suddenly: no HA or NodeRed updates, just one morning NR refused to start at all… I’ve identified that if I change browser (currently running Edge) I can access NR, but even if I do a full clean of the browsers cache and reboot my Raspberry, the issue still persists…

Same here! It was working 3 Days ago! No me of alternative posted here worked for me!

I also have the same problem when I use Chrome. With FireFox and Edge so far no problem.

I opened this issue on GitHub so maybe we can’t get shed some light on the origin of this issue:


For those who still have this issue, there is a discussion going on in the official Node-RED forum about it.

Good news everyone!

1 Like

Hi to all!
In my case the problem was solve with the 9.1.0 version of Node Red.
Im sooooo happy now!