Nortek/GoControl GD00Z-4 quit working after 2021.10.4 Update and ZwaveJS Update

I have a GoControl GD00Z-4 that quit working after I upgraded to 2021.10.4 and Z-Wave JS to MQTT 0.27.0.

I was previously running 2021.8.8 and Z-Wave JS to MQTT 0.22.1.

I have tried Excluding and Including the devices again and Factory Resetting the GoControl. I suspect the issue may be that the GoControl keeps getting included back in with no security even when I tell it to use S0 encryption.

Any ideas, or just wait for an update?

Mine was still working after the Z-Wave JS upgrade, but didn’t do the MQTT. Then recently one of the updates it stopped opening the door. That or it’s broke. Instructions I have don’t show a manual test button or anything. But when till it to open the door like before it beeps the up arrow goes gray like going to open and then goes back normal with no action.

Seems like I have a lot of stuff needing repair or breaking down. Just add this to the list now.

Got my GD00Z-4 garage door opener working again. Found the answer at Linear Garage Door Opener Stopped Working - #63 by N8Bear - Connected Things - SmartThings Community by: timnord

Mine would beep and even the Warning Light was working, but did seem less illuminating then before. Learned there that I guess that is part of the ‘barrier’ and if out of spec or not working, will not open or close the door. Well, there are several fixes, replace the LED, replace it with resistors with or without a diode to draw the same current thru the circuit, so it see’s the LED as functional. Seem that a lot of people are having problems with this LED and is a failure point.

I opted for 5 16ohm 1/4 watt resistors (approx 3.2 ohms) in series with a IN1004 diode. the anode of the diode (if you use one) should be on the furthest pad from the piezo buzzer. Was kinda sceptical if that was my problem since the LED seemed to be working.

After opening and closing the door manually a couple times, it WORKED! You do have the 30 wait time between actions, so if try to close right away it won’t. But after that it does. Have seen the controller get ‘lost’ if try to push the opposite action too soon. Then have to manual operate, but much better than not working at all.

So even if you have a functioning LED warning light, it might be out of spec and be your problem. Worth a shot.