Not discovering devices after installation in a VM

So, after installing hass on a VM it doesn’t discover device “made adoptable”. Before, I ran a supervised installation and it discovered my module (nodemcu) without any problem.

Did you flashed it earlier wit ESPHome or is it a new device?
How did you connect it? USB (on VM or local machine) or on your LAN (same or different segment)?

BTW, Welcome to the HA family! :+1:

1 Like

On the device the “make adoptable” thing is installed. It’s reachable from my local network aswell as my VM. I tried installing via usb from my hass, but I couldn’t start installation.

By coincidence, i just started to play with the ESP32 NodeMCU. I use also a VM (Synology VM Manager). I noticed sometimes I had have to reconnect the VM USB to get it working (again), even restart HA.

To answer your question:
I use API password and encryption key in my NodeMCU config and the NodeMCU is (also) not discovered. I did that manually by adding the NodeMCU by adding (a second) ESPHome integration (integration menu). It will ask for the IP, Encryption key (when configured) and Password (when configured).

When valid, it is added to HA.