Nothing Works on New Version

I have 2 RPIs running HASS currently. The old one I could not update anymore due to python. I installed a new Hassbian OS install on the new one.

I noticed the configuration.yaml is completely different and missing almost everything, even stuff that was pre-configured in the older versions.

I added a few things in the configuration.yaml and tested for errors. There were no errors, but after a reboot nothing new is there. This is nothing new, it seem like everytime HASS is “updated”, everything is broken afterward.

Here is my old configuration.yaml:

homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: latvalue
  longitude: longvalue
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 251
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: America/Chicago
  # Customization file
  customize: !include customize.yaml

# Show links to resources in log and frontend
# introduction:

# Enables the frontend
frontend:

# Enables configuration UI
config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Checks for available updates
# Note: This component will send some information about your system to
# the developers to assist with development of Home Assistant.
# For more information, please see:
# https://home-assistant.io/blog/2016/10/25/explaining-the-updater/
updater:
  # Optional, allows Home Assistant developers to focus on popular components.
  # include_used_components: true

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Enables support for tracking state changes over time
history:

# View all events in a logbook
logbook:

# Enables a map showing the location of tracked devices
map:

# Track the sun
sun:

# mFi Switch
switch:
  - platform: mfi
    host: 10.100.0.199
    username: username
    password: password
    verify_ssl: False
    
# mFi Sensor and Weather prediction
sensor:
  - platform: mfi
    host: 10.100.0.199
    username: username
    password: password
    verify_ssl: False
    
  - platform: yr

# Text to speech
tts:
  - platform: google_translate

# Cloud
cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

Here is the new config:

# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# mFi Switch
switch:
  - platform: mfi
    host: 10.100.0.199
    username: username
    password: password
    verify_ssl: False

# mFi Sensor
sensor:
  - platform: mfi
    host: 10.100.0.199
    username: username
    password: password
    verify_ssl: False

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

Why isn’t anything showing up besides the weather, user, sun, and updater? All of which are not even in the configuration.yaml.

what version have you updated from?

If you’re referring to stuff in secrets.yaml it needs to be formatted with !secret first:

hacs:
  token: !secret my_github_access_token
  theme: true

like that.

thins like latitude and longitude can still be put in the configuration.yaml or specified in the UI now.

The working version with the old configuration.yaml is 0.96.5.

I don’t care about lat and long, that works by default with the first time boot settings.

I also never did secrets.yaml, the username and password fields have just been edited here to not post them for the entire world to see. In the actual config, they have the correct username and passwords.

The mFi switch and mFi sensors are controls for turning off and on outlets and other devices. I also get sensor data like the amps my breaker box is pulling at all times.

None of the mFi stuff shows up on the new one with the current version of HASS.

I tried downgrading to 0.96.5 and I have the same issue.

I was looking and messing with stuff and the logs now show that it is trying to connect, but fails due to an SSL error.

I changed the hostname to the FQDN that the SSL cert is signed for. I changed the settings relating to SSL in order to match.

Still the same error. I think it is cause by something that updated between Stretch and Buster. I have seen some other posts complaining of errors after openssl was updated.

SSL routines', 'ssl_choose_client_version', 'unsupported protocol

How can I fix this. UBNT mFi can only run on Ubuntu 14 and will never be updated.

There is a whole page every release related to breaking changes. These ‘nothing works’ posts are draining. Do your due diligence like everyone else and read the breaking changes and make your fixes. Or don’t update (like I did for a whole year). Updates in this pre-release software aren’t going to go swimmingly like a normal fortune 500 company release schedule. With every release you should expect changes until the product has been officially released with a 1.0 build.

2 Likes

My bad. I was under the assumption the purpose of this forum was to get help when things break or when someone is having issues setting something up.
The comment you quoted was a observation, one that many people have also found to be true.
As far as making my fixes, that’s exactly WTF I am trying to do.
Hopefully there are some more helpful people here that can come up with a helpful reply so I can get the main thing I use Home Assistant for working again.
Also, if you read the entire post you would know I still have my old one running that is working just fine. There was a reason I did not overwrite that one. I can abandon this at anytime, but would like to be able to get updates, because along with the Breaking Changes, there are some decent ones also.

If anyone else runs into the openssl issue, this worked for that:

Although, I realized HASS didn’t actually update when I tried after downgrading. So it’s broke again due to the configuration.yaml.

Actually, I lied. It just took a bit to start after update.

So I downgraded HASS copied the old config.yaml. Fixed the OpenSSL issue that buster introduced. Updated back to current and everything works. The update must have made the necessary changes to the config.yaml that was causing it to fail after copying it from the old version.

A new install has default_config that loads a number of items by default. To customise you need to remove it and add back the items it loads manually. Look at the integration called default_config and what it loads by default

I recently have done the same thing. I could not upgrade any more due to python, so I started over from scratch with a fresh install of Hassbian. I took all of my configs from the old install and uploaded them to the new install. Then I used this site to find all the breaking changes:

https://hachanges.halfdecent.io/

I fixed all the breaking changes then restarted Homeassistant, and I was up and running.

1 Like

That was the first thing I tried. I renamed the default config to .old and copied my old config in. It wouldn’t start HASS afterward so it didn’t like it. That’s when I tried the config posted here.

The main issue that I needed fixed was actually not caused by Home Assistant in the end though, it was an updated version of openssl when I moved to Buster.