NR service call: thermostat {"hvac_mode" : "off"} has no effect

All,
I am a bit puzzled about a service call, which apparently does not go though.

I am trying to set a Danfoss Ally thermostat to “off”, in the following way:

I deploy and run it (notice the timestamp on the node)
Skærmbillede fra 2021-10-10 15-22-57

A check in the logbook gives this:

Other observations:

  • no errors in the node-red/amd64:10.0.0 container logs
  • no climate errrors in the qemux86-64-homeassistant:2021.10.2 container

Any ideas to obvious errors or how to debug this further ?

Regards
Per

Just as a test, see if climate.turn_off works?

Thank you for the hint:

  • no log entries in either container
  • no entry in the the log for the entity
  • no changes in the entiry, as shown on the developer tools page

I tried to turn off a single lightbulb and turn it on, using the service call node - it works as expected and do produce entries in the logbook.

As a workaround,
I set the temperature to 10 degrees Celsius - that works using the "set_temperature" service with this JSON data: {"temperature" : "10"}

The climate.turn_off method notes that it will only work if the entity you are trying to turn off supports hvac_mode: off so perhaps the thermostat doesn’t actually support off?

that might be the case - will do some googling on the subject.
Thanks for that hint.

1 Like