Nut client parameter need help

Hello,
I have configured a nut server. it run well.
I try to organize the nut client on home assistant.
Here is the config:

users:
  - username: home_assistant_client
    password: xxx
    instcmds:
      - all
    actions: []
devices:
  - name: Back-UPS
    driver: usbhid-ups
    port: /dev/null
    config: []
mode: netclient
shutdown_host: 'false'
remote_ups_host: 192.168.1.107
remote_ups_name: upsmon on localhost
remote_ups_user: home_assistant_client
remote_ups_password: xxx

In the section users I declare the user on the upsd.users from the host.
So, what are the variables:
remote_ups_name,remote_ups_user, remote_ups_password ?

When I start the addon, I receive the following:

[21:47:06] INFO: Starting the UPS monitor and shutdown controller...
Network UPS Tools upsmon 2.7.4
   0.000000	fopen /var/run/upsmon.pid: No such file or directory
   0.000058	Using power down flag file /etc/killpower

Fatal error: insufficient power configured!

   0.000140	UPS: upsmon (monitoring only)
Sum of power values........: 0
Minimum value (MINSUPPLIES): 1

Edit your upsmon.conf and change the values.

The upsmon.conf file is used on the client machine ie Home Assistant ?

Many thanks for your help.

Thierry

+1

Trying to use the add-on to configure netclient to monitor UPS on my Synology NAS (on which I have configured everything for another NUT client to be able to connect to get data about the connected CPS UPS).

I had the same issue.
The solution for me was to use a value for remote_ups_name which does not contain any spaces.

Trying to get this integration working, but hopelessly stuck…

I’ve got an EATON 5PX connected via USB to a Ubuntu VM (on VMWare), setup the NUT server, which is running and working. My HA runs in another VM (also VMWare).
So my “mode” is netclient, but really can’t figure out how to fill in all the rest of the YAML. Currently, I’ve got this:

devices:
  - config: []
    driver: usbhid-ups
    name: EATON 5PX
    port: auto
mode: netclient
shutdown_host: 'false'
users:
  - actions: []
    instcmds:
      - all
    username: NUTSERVER USERNAME
    password: NUTSERVER PASSWORD
remote_ups_name: mace-nut-server
remote_ups_host: 10.0.1.135
remote_ups_user: NUTSERVER USERNAME
remote_ups_password: NUTSERVER PASSWORD

From the log I get:

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] nut.sh: executing... 
[01:45:29] INFO: Setting mode to netclient...
[cont-init.d] nut.sh: exited 0.
[cont-init.d] nutclient.sh: executing... 
[cont-init.d] nutclient.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[01:45:30] INFO: Starting the UPS monitor and shutdown controller...
   0.000000	fopen /run/nut/upsmon.pid: No such file or directory
   0.000250	Using power down flag file /etc/killpower
   0.000495	UPS: [email protected] (slave) (power value 1)
   0.000599	debug level is '1'
   0.000694	Warning: running as one big root process by request (upsmon -p)
   0.000895	Init SSL without certificate database
   0.001958	Trying to connect to UPS [[email protected]]
   0.002679	UPS [[email protected]]: connect failed: Connection failure: Connection refused
{"message": "Event nut.ups_event fired."}Network UPS Tools upsmon 2.7.4

Any ideas?

Its very important that the remote_ups_name: matches the name of the UPS on the nut-server. In my case I had just called it ups, because I only have the one. Once I put the correct name, everything worked.

@Mace I’m getting the exact same error message but haven’t worked out a solution yet. Have you had any luck? I’m running NUT server on my proxmox host IP address in netserver mode and attempting to configure my HA VM as a netclient via the Network UPS Tools Add-on in HA.