One sensor not displaying in Grafana, but ok in HA

Hi, using Home Assistant OS, latest version. Integrated with Deconz/ConbeeII running on a separate raspberrypi. Dozens of sensors, all ok.

One new sensor (aqara temperature) is visible in deconz, and is showing live temperature data in home assistant, but the entity name is not making it into Grafana. I have tried looking in influxDB - and I don’t think its getting into there either, but I may be getting the query wrong. I’ve tried deleting the sensor in phoscon and readding with a new name to no avail.

How can I troubleshoot this please?


Double check the entity name in dev tools don’t go by the name that populates in lovelace, as it maybe different. If it’s there go to the sidebar choose history and search for the entity, see if any records are present.

Building up on @Mikefila’s post, make sure the entity is not excluded from the influxDB integration in your config (check entity_globs and domains).

These inclusions/exclusions are different from the ones of the recorder and history integration.

You could also try to specifically include your entity in the influxDB configuration.

Doing that excludes everything else, this requires you to enter everything you want to track manually.

If set, all other entities will not be recorded to InfluxDB.

Thanks all, no luck yet. The sensor name is correct, and I can see it regularly updating in history. No specific influxDB configuration - no excludes etc.

Anything else I can try?


hmmm you’re choosing the unit first in gafana? F or C? Try the opposite and see if you find the entity or just search the entity first before the unit of measurement.

Great idea but still not there! I don’t have degrees F, and it doesn’t show on the pick list for entities if I start with that. Really appreciate the pointers though, no clue why it might not be making it into influx if all the other sensors are.

Domains can be listed and then manually included in the config file with:

{% for d in states | groupby('domain') %}- {{ d[0] }}
{% endfor %}

Fast and easy.

  • Create a custom sensor for the temperature attribute of your aqara device and see if this one goes through.
  • Setup a new temporary database and see if it works then.

Having the same problem.
Aqara Lumi Zigbee sensor (Temperature) is not showing up in Grafana … no matter what I try :frowning:
Did anybody resolve this?
Is there anything else I can try?

Thank You!