OpenMQTTGateway Question

Ok - I got the gateway up and running last night with an ESP32 and I can see it reporting in what appears to be my google homes and chromecast into my MQTT server.

The question I have is this - I was expecting to use it to detect my phone like the bluetooth tracker does on an rpi3 ( but so far as I can tell, the gateway does not see my phone unless I’m running some kind of beacon simulator or something like that.

Can someone point me in the direction of getting the gateway to see my phone? It worked perfectly with the rpi3 bluetooth module but I’ve moved into docker and don’t have that ability now and so this was my soltuion was to use openmqttgateway and let it do the tracking for me.

Thanks ahead of time for any help you guys can offer!

I ended up testing the beacon simulator app (on google play) - the problem is that the mac address changes every time the simulator restarts - or you restart your phone etc. So no good from what I can tell unless I missed something.

As a result, I ordered to HM-10 modules and will attempt to make my own powered beacons - we’ll see how it goes!

What HM10 modules did you ordered?

There are genuine modules (around 8-10 EUR) and some cheap ones (clones such as AT-09) at less than 1 EUR, however they can be easily flashed with the HM10 firmware. I found this youtube video and is quite useful for flashing. On the OpenMQTT’s Gitter page you can find more discussions about this.

1 Like

@Petrica - Thank you so much for that article - looks like I got the cc-41 - this is what I ordered -

That article and video should be quite helpful when they arrive - much appreciated!

I got this going this weekend. Wasn’t too bad at all… I ended up not flashing the cc2541 with the HM-10 firmware as I found out I could run the commands I needed to get it going without the firmware. The OpenMQTTGateway was able to see the ibeacon when I was done and it’s reporting in to HASS via MQTT properly so far as I can tell at this time.

This article put me on track with not replacing the firmware on the module I ordered -

Also - in my case with my module (could be different per module…) - I noted on most of the commands, if I put a ? behind the line and sent it using the utility from the article I linked - it would run the command. So AT+NAME? would work whereas AT+NAME would do nothing - but AT by itself would return OK - so definitely kind of wonky. I picked up on the ? as I was reading some other articles about the CC2541 - just happened to see it and try it.

The one piece I’m still fighting with is Owntracks using the Ibeacon on Android. I according to NRF Connect - I have the right UUID and major/minor - but I can’t tell if Owntracks is using the ibeacon or not at all. If anyone has any input on this - let me know - I dug around and tried some things others have talked about but it doesn’t seem to be working.

When I get that working - I’ll be looking good, but so far the openMQTTgateway and the CC2541 and MQTT seem to be working well. Just wanted to report back with what I found.

Sonoff 433MHz Wireless RF
not get any messages any more im on Home Assistant
any help is appreciated

when you say anymore, what is the last change you did before it breaks?