OTA Update failing - Obsolete PIO Core

Trying to update a NodeMCU OTA but it keeps failing. The file validates but when I try to upload I keep getting the below error. I’ve had a look around but can’t seem to find any answers.

I’ve not had any issues with OTA updates previously. I’ve recently updated to the latest version of ESPHome, so not sure whether that’s the reason or if it’s just coincidental.

image

Try a ‘clean build files’ from the overflow menu.

I’ve just tried the Clean Build Files, then hit upload again with the same results

How did you install esphome?

I’m using the HA integration to build the files. The first flash of the device I did was using the esphome flasher, but then after that have been using the HA integration OTA.

Are you referring to the addon? ESPhome doesn’t come as an integration.

Sorry, yeah the addon

Managed to get the update to work through the command line, but still no luck with the HA addon

Which version of the addon you are running? And which (pip3?) command line version?

Addon version 1.18.0 and pip 21.1.1 (had to google how to find the pip version, so hope that’s correct)

Ok, addon is up2date. The esphome version you installed with pip3 is usually retrieved by just typing esphome version into the command line. Will be 1.18.0 too I guess.

I would try to delete the esphome addon from ha and than install it again. The obsolete (old but used) pio core will then most likely be gone and everything will working again.

OK cool thanks, will give it a go. Possible noob question, but if I delete the addon and then reinstall it, will all the integrations still be there? Or will I have to re-add them?

The integrations are completely independent from the addon (which is mainly to create and edit esphome nodes with yaml). The integrations itself are managed by ha and they will continue to be as they are not matter you have the addon installed or not.

Your yaml files should also survive a uninstall but best to back the up.

That looks to have solved the issue. Thanks heaps.