Owntracks Waypoints Issue

Hey,

Has anyone got waypoint importing working with HA? I cant for the life of me work it out.

Owntracks is working fine and reporting my location to HA. I’ve even got remote commands working.

In my configuration.yaml file its setup as so:

    - platform: owntracks
      waypoints: True

I haven’t setup a whitelist so at the moment as according to the documentation by default it will allow everyone access to publish waypoints (correct me if I’m wrong here)

To test waypoints are exporting I subscribed to the topic “owntracks/phones/Ross’s iPhone/waypoint”

On the iOS app when I go into settings and push the Publish waypoints button I can see my waypoints being pushed via MQTT so I know thats working.

However the problem is that nothing is showing up either on the map or in the states section on the developer tools.

Maybe I’m missing something? Any ideas?

Just to add this this,

I have created a script in scripts.yaml to publish a command via MQTT to refresh my device but nothing happens. If I subscribe to the topic I’m publishing to in the script I don’t see anything come through

  device_refresh:
  sequence:
    - service: mqtt.publish
        data:
          topic: "owntracks/phones/Ross's iPhone"
           payload_template: '{"_type":"cmd","action":"reportLocation"}'

It never worked for me either no matter what I tried. I ended up just manually copying the waypoints into HA as zones using the same coordinates and radius.

Can you explain for me how you manually exported the waypoints and added them to HA please?

Unless someone else here has got this working as it should be and can help out?

I used owntracks export function while listening to the subscription in a terminal over ssh.

Log in with ssh and run
mosquitto_sub -p 1883 -d -v -t /#
(if that’s your port number ofcourse) Ctrl-C to stop listening to new messages.

After that I copy-pasted the coordinates and created the zones from that data in a text editor. Once it was working I removed the waypoints in owntracks.

I dont have any issues with this one.
Just add owntracks to config as normal,
Be sure to check “Share” in your owntracks app and then go to “Preference”-> Export
I use whitelist.