Painless upgrade via docker

Running a separate zwave-js container. Every tim i upgrade the settings are just blown off - have to enter once again S1, S2 keys to get it started. Believe there is a problem with my docker compose config. Maybe someone can help

$ cat compose.yml

#https://zwave-js.github.io/zwave-js-ui//#/getting-started/quick-start
version: '2.4'
services:
  zwave-js-ui:
    container_name: zwave-JS-Correct
    image: zwavejs/zwave-js-ui:9.1.2
    restart: always
    tty: true
    stop_signal: SIGINT
    environment:
      - SESSION_SECRET=xxx
      - ZWAVEJS_EXTERNAL_CONFIG=/localpath/Docker/zwave/.config-db
    networks:
      - zwave
    devices:
      - '/dev/serial/by-id/usb-0658_0200-if00:/dev/zwave'
    volumes:
      -/localpath/Docker/zwave/:/usr/src/app/store
    ports:
      - '8091:8091' # port for web interface
      - '3000:3000' # port for Z-Wave JS websocket server
networks:
  zwave:
volumes:
  zwave-config:
    name: zwave-config

You don’t need that, messes up the device database by providing an incorrect path, as /localpath does not exist inside the container.

You are missing a space here to create a YAML list. Quotes don’t hurt either. Because of this, the settings and driver cache files are deleted every time you update. It should be:

      - "/localpath/Docker/zwave:/usr/src/app/store"

/localpath/Docker/zwave is where you are specifying the container files to be saved on the host, is that the right path?

You don’t need this, unless you have something else in this network?

You don’t need this if you are using /localpath. Currently this volume unused.