Panel_iframes not consist

Hi all.

I am setting up panel_iframe links to reduce all the port forwarding required to check stuff remotely.

Initially everything worked out nicely but as time went on (and a few restarts of HA) the links have stopped connecting randomly - mostly the none HA links but all at various times.

Any idea what, where, how to investigate?

configurator:
** title: Configurator**
** icon: mdi:wrench**
** url: !secret configurator_url**
** nodered:**
** title: ‘Node-Red’**
** icon: ‘mdi:shuffle-variant’**
** url: https://192.x.x.x:1880**
** pihole:**
** title: ‘piHole’**
** icon: ‘mdi:pi-box’**
** url: ‘https://192.x.x.x:4865’**
** router:**
** title: ‘Router’**
** icon: ‘mdi:router-wireless-settings’**
** url: ‘https://blah.duckdns.org:8443’**
** portainer:**
** title: ‘Portainer’**
** icon: ‘mdi:docker’**
** url: ‘https://192.x.x.x:9000’**
** plex:**
** title: ‘Plex’**
** icon: ‘mdi:plex’**
** url: https://192.x.x.x:32400/web/index.html**

Hi, You can use quotes like ‘text’ but your example contains backticks.
Quotes are only required when you use names with spaces.

I think your code should look like this:

panel_iframe:
  configurator:
    title: Configurator
    icon: mdi:wrench
    url: !secret configurator_url
  nodered:
    title: 'Node-Red'
    icon: 'mdi:shuffle-variant'
    url: https://192.x.x.x:1880
  pihole:
    title: 'piHole'
    icon: 'mdi:pi-box’
    url: 'https://192.x.x.x:4865'
  router:
    title: 'Router'
    icon: 'mdi:router-wireless-settings'
    url: 'https://blah.duckdns.org:8443'
  portainer:
    title: 'Portainer'
    icon: 'mdi:docker'
    url: 'https://192.x.x.x:9000'
  plex: 
    title: 'Plex'
    icon: 'mdi:plex'
    url: https://192.x.x.x:32400/web/index.html

One other thing: If you publish code in this forum, please use </> from the menu to preserve the spaces in your code. Just select your code and click on then </> icon.

I hope this helps you!