Please Help! NSPanel Not Responding

Really hoping someone can help me! And do so in a gentle way…

I’ve been trying to get to grips with ESPHome and the NSPanel for a few weeks now and nothing has been working the way it is portrayed in the guides on Youtube. Now I am certain the issues lay with me and my lack of understanding, but I really don’t know where I am going wrong.

Until this morning, my issue was that the tft upload service call woudn’t work. Seems that running HA on a docker complicates this part in a way I can’t fathom. It just wasn’t accessing the file, and without the file editor add-on, I had no way to upload. Did some linux-ing to put the tft where I thought was right… no luck.

But that aside, I now can’t get comms with the NSPanel.

From https://web.esphome.io/ and having a serial connection, I can flash the device. I can send .bin files that are already configured or I can “Prepare for Adoption” (what ever that means?). The Logs show nothing whilst connected.

I have no way of accessing the “Compile” part of the process, and no way of access the Secrets file.

I now have a blank screen and seemingly no way to recover it.

However, when powered with 5v (rather than 3v3 for programming) HA does detect the NSPanel and report button presses etc.

I’m so confused with this all now and just want to get the NSPanel back working again.

And also, if anyone has a step by step guide on flashing the NSPanel FROM A NON-SUPERVISED HA INSTALLATION I will make you cookies!

I think I am getting disillusioned with it because each step requires more and more knowledge that I haven’t got and can’t find.
Simple things like in the video they use the ESPHome integration. Which I can’t use or install as the I am unsupervised. So how can I build the .bin or secrets files?
It also says “upload the tft file using the file editor”… but unsupervised doesn’t have file editor.
And adding file editor doesn’t appear to be an option. The guides on doing that are complex and when I follow them I get linux errors.
So I try and create the directory manually, but that doesn’t seem to share so the NSPanel can’t download…
:frowning:

I am not sure (or actually… I very much doubt) if your assumptions on HA/docker have anything to do with this.
Not sure what is going on but you could try to load the original bin to it, this you could (or possibly have to) do via cabled connection as per the very first load

What I mean is having HA as unsupervised makes the process a lot more complicated and inaccessible to me as an untrained computer person… I know principles but not details.
So uplaoding hte TFT file for example is 100% more diffoicult due to running unsupervised. You can’t upload it directly meaning sharing then runs in to the brick wall of linux sharing protocols :frowning:

I have now managed to recover it… sort of.
The screen is back on.
But I can’t access the ESPHome dashboard of the unit at 192.168.0.78:6052 as I could before. (IP Adrress confirmed correct in HA).
This means still no access to logs or the yaml files for this device

Does the nspanel have a sd card? If so you can upload a tft file.

You don’t need the supervisor or docker to run esphome.

Nope no SD card. Storage is all on-chip
Manually uplaoding a TFT would be the ideal solution!

I really don’t know what you mean. The yaml file is wherever you put it. Any editor can edit it.

Perhaps you need to actually post what you have done, and what results you got.

So I used the Mark Watts youtube guide.
In that he uses the ESPHome HA addon (which I can’t use).
But I was able to access the same via a browser. So I had the option to edit the yaml and secrets files.
You then click “install” and it compiles the yaml in to a .bin which you then download.
This is then flashed to the NSPanel via the web interface and a serial connection.

However, as it stands, I can no longer get to the page where I can compile the yaml and secrets files in to a .bin.
Or “Add a new device” as per the videos

You can’t have it both ways. Either you can, or you can’t.

I could.
Now I can’t.

So I managed to recover it by flashing it all the way back and starting again from scratch.
But I still can’t upload a tft file to it using the service call from HA

The logs just say “[13:00:46][D][nextion_upload:160]: connection failed”

What is the simplest way of pointing this thing at a valid URL (thats what seems to be needed) without having to mess around with linux (or worse, Microsoft!) securtiy? Surely there is way I can make a tft file locally available on my network, simply and without having to open ports on firewalls, or have use accounts to do it.
The HA share just isn’t working for me. I have tried putting the tft file in the www folder manually but I can’t access that other than via sudo on the local server.

I still get 403: Forbidden when accessing 192.168.0.HomeAssIP:8123/local/ from another machine on my network.

The plot thickens…
I went all out. Setup a new HA instance on a raspberry pi.
Competlely cut out the previous one.

AND I STILL GET THE NEXTION UPLOAD: 160 ERROR!!!

Someone must have an idea of what on earth is wrong now?

Stop shouting.

Tell us exactly what you did, not by reference to a video.