Powerwall integration fails on incorrect PW versions

Intermittently my instances fails to pull data from our Powerwall gateway.
The error in Lovelace is; Unknown powerwall software version

It seams like your powerwall uses an unsupported version. Please update the software of your powerwall or if it isalready the newest consider reporting this issue.
See logs for more information

iOS error screen-grab → https://drive.google.com/file/d/1q8k7d4n3B5e7Hea9OYB7f7U5HZVWOzSY/view?usp=sharing

I have yet to figure out how to pull my HA logs out into a rsyslog server, so I’l post the logs next time this occurs.

Should I also post the ‘issue’ to Github?

Our Powerwall in Australia is running 1.46.0. I do not believe it is possible to force an upgrade.

Thank you by the way for the integration