Problem after 0.40 to 0.42.3 upgrade

Today I upgraded from 0.40 to 0.42.3. After rebooting, on my main screen I get Invalid Config for these components:

The following components and platforms could not be set up:
history
recorder
logbook
Please check your config

I ran the check_config script and my config passes without any errors. Any idea why I’m getting conflicting information?

I had the same issue and found another thread that suggested deleting the “home-assistant_v2.db” file, which I did, and it solved my problem. You will lose all history if you do this.

@hoffsta… You da man. That fixed my problem as well. Thanks!