Problem with configuring Dyson Fan

Trying to add a Dyson HP04 but without any luck.

In configuration.yaml I wrote

  username: userid
  password: password
  language: GB        (I've also tried SE for Sweden where I live)
    - device_id: XXX-XX-XXXXXXXX
      device_ip: 192.168.1.nnn

But I only get:
Unable to find device XXX-XX-XXXXXXXX in Dyson account

I can see the unit in my Dyson app but not on “My Dyson”. I’ve spoked with Dyson and they can see that the unit is registered. (When I tried to register it on the web it says: serial no invalid)

Anyone got a clue?

Regards, Mårten

Yeah i have the same issue but in the au region also with the hp04

Think they are just yet to add support as with the tp04 and dp04

I am not sure how to flag it so that it can be added though

Did you find a solution Mårten? I have the same issue…

No, not yet. It seems like TP04 and DP04 models are working but not the HP04. At least not now.
Can you see your unit if you log into “My Dyson” on the web? I cannot see mine but when I call Dyson they can see that it is registered but for some reason does not yet show up on “My Dyson”.

Yeah, I can see it on the “My Dyson” section. But in Home Assistant it says:
Unable to find device A1A-EU-XXXXXXX in Dyson account

But I found two things that might be interesting.
When using my country, the one I used setting up the Dyson with.

  username: xxxxxxxxxxxxxx
  password: xxxxxxxxxxxxxx
  language: DK  
    - device_id: xxxxxxxxxxxxxx
      device_ip: xxxxxxxxxxxxxx

it says: Not connected to Dyson account. Unable to add devices.

But when using GB in the config:

  username: xxxxxxxxxxxxxx
  password: xxxxxxxxxxxxxx
  language: GB
    - device_id: xxxxxxxxxxxxxx
      device_ip: xxxxxxxxxxxxxx

It says: Unable to find device A1A-EU-XXXXXXX in Dyson account

So for some reason, it seems to be linked to “smaller” nations?

1 Like

I will check that myself later this evening. I can however not see my unit when I logg into any of the My Dyson accounts (Sweden or USA). The helpdesk at Dyson in Sweden say that they can see the unit registered on me but I cannot see it myself for some reason.
When I try to register the unit, I get “invalid serial number”.
I just sent them an email to see if they can support in any way.

They really don’t make it easy for us :smile:
Do you mind passing on the information you get, when answered?

Absolutely. Just tried to see if I got the same error codes as you and I did. When trying with SE for Sweden I got “not connected” and when trying GB i got “unable to find device”.
I have registered a My Dyson account on both and and since I have different passwords on them I could conclude that HA is only trying the account registered on
I keep you informed when I get more info.

1 Like

Will try it too. Country it

Any of you guys got it working?

Not yet. Will post here when/if I get it working

Nope no luck

Damn. Maybe I should try getting in touch with Dyson Denmark!

I had my Dyson fan working in NL, for about a month.
After an update or reboot I kept getting this error: “Not connected to Dyson account. Unable to add devices”

I found out (for the second time) that the account in the app and on the website are two different accounts. I reset the password for the app, logged in and setup the fan in the app. When I put the password I used in the app in HA the connection error disappeared and I’m able to control my fan.

Probably some error on my end in my case, but maybe you can use the info.

Thanks for the info, but I’m still not able to use it…
Did you find a solution?


was just wondering whether anyone was able to connect their dyson pure humidify+cool?

keep getting the “Unable to find device C4H-EU-NAA6639A in Dyson account” message

I have the same issue with the pure humidify+cool. I don’t think it’s added to the components yet (it’s not in the list of supported devices).