Problem with OpenTherm Gateway integration in 0.101.2

I have a problem adding OpenTherm gateway through Integrations in newest version of HA.

When I enter name ‘Boiler’ and path ‘socket://’ and press ‘Submit’ it take couple of second and fields name and parth are empty and there is no OpenTherm Gateway in integrations.

What could be the problem? Is it necessary to have boiler connected with gateway while adding to HA?

I bought my gateway from, I have version with NodeMCU. After I’ve received gateway I was not able to connect with it to enter my WiFi setting I had to install ESPEasy and configured it, maybe that’s the problem? Below is my NodeMCU configuration:

Thank you

Any suggestions?

I installed the same with nodemcu without problems. Off course configure as told in the manual. Used the open therm gateway script from home assistant, working without problems.

Thank you for replay.
Could you give the url’s for manual and script? Because I think that couple of days ago the documentation for OpenTherm was changed and now you can add OpenTherm only through integrations and I never saw manual how to configure nodemcu for OpenTherm gateway. Thanks

It’s on the website of nodo
Last pages is about the nodemcu, but it’s in Dutch

Problem is solved. I didn’t had two jumpers on the board. I’m not sure if they should be in set and mounted but they weren’t.