Problem with tado component

Guys I have recently bought tado and I am trying to integrate it into Home Assistant but it does not work.

I cannot turn it off and I cannot switch to cool mode. When off and try to change temprature I am getting http 422

HTTP Error 422:
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/websocket_api/commands.py”, line 128, in handle_call_service
connection.context(msg),
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1235, in async_call
await asyncio.shield(self._execute_service(handler, service_call))
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1260, in _execute_service
await handler.func(service_call)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 210, in handle_service
self._platforms.values(), func, call, service_name, required_features
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 334, in entity_service_call
future.result() # pop exception if have
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 356, in _handle_service_platform_call
await getattr(entity, func)(**data)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/climate/init.py”, line 416, in async_set_hvac_mode
await self.hass.async_add_executor_job(self.set_hvac_mode, hvac_mode)
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/tado/climate.py”, line 269, in set_hvac_mode
self._control_heating()
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/tado/climate.py”, line 388, in _control_heating
self._store.set_zone_off(self.zone_id, CONST_OVERLAY_MANUAL)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/tado/init.py”, line 135, in set_zone_off
self.tado.setZoneOverlay(zone_id, mode, None, None, “HEATING”, “OFF”)
File “/srv/homeassistant/lib/python3.6/site-packages/PyTado/interface.py”, line 287, in setZoneOverlay
data = self._apiCall(cmd, “PUT”, post_data)
File “/srv/homeassistant/lib/python3.6/site-packages/PyTado/interface.py”, line 81, in _apiCall
response = self.opener.open(req)
File “/usr/local/lib/python3.6/urllib/request.py”, line 532, in open
response = meth(req, response)
File “/usr/local/lib/python3.6/urllib/request.py”, line 642, in http_response
‘http’, request, response, code, msg, hdrs)
File “/usr/local/lib/python3.6/urllib/request.py”, line 570, in error
return self._call_chain(*args)
File “/usr/local/lib/python3.6/urllib/request.py”, line 504, in _call_chain
result = func(*args)
File “/usr/local/lib/python3.6/urllib/request.py”, line 650, in http_error_default
raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 422:

1 Like

Same here… Tado show current setting, but I can’t change status. Error 422

It’s because the Tado component doesn’t support devices that allow you to set Fan Mode.

It doesn’t work with TADO Heating too… And it doesn’t have any Fan Mode.