Problems with displaying add-on's in panel_iframe

Im running hassio with duckdns. I can log in with https://mydomainname.duckdns.org:8123 with no problem locally or remotely.
But locally i’m having trouble with opening components in panel_iframe. Ive tried so many different settings and am now totally confused as to what should be what.

My configuration.yaml is:

http:
   base_url: mydomainname.duckdns.org:8123
   api_password: password1
   ssl_certificate: /ssl/fullchain.pem
   ssl_key: /ssl/privkey.pem

panel_iframe:
  configurator:
    title: Configurator
    icon: mdi:wrench
    url: https://192.168.1.63:3218

  influxdb:
    title: InfluxDB
    icon: mdi:chart-areaspline
    url: https://192.168.1.63:8888

Duckdns config is:

{
  "lets_encrypt": {
    "accept_terms": true,
    "certfile": "fullchain.pem",
    "keyfile": "privkey.pem"
  },
  "token": "tokenfromtheduckdnssite",
  "domains": [
    "mydomainname.duckdns.org"
  ],
  "seconds": 300
}

Configurator config is:

{
  "username": "username",
  "password": "password",
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "allowed_networks": [
    "192.168.1.0/24",
    "172.30.1.0/24"
  ],
  "banned_ips": [
    "8.8.8.8"
  ],
  "banlimit": 0,
  "ignore_pattern": [
    "__pycache__"
  ],
  "dirsfirst": false,
  "enforce_basepath": false,
  "notify_service": "persistent_notification.create"
}

And my InfluxDB is:

{
  "log_level": "info",
  "auth": true,
  "ssl": true,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"
}

When I do get it to work, Chrome returns saying the site isn’t trusted and I have to except to open the scripts, once this is done hassio then shows ‘un secure https’ in red from then on.

I have ‘Multi-factor Authentication’ enabled if that makes any difference.

Im just lost now on this and need some guidance. Thank you.

I am using the Configurator addon too. I forwarded port 3128 through my router and changed the iframe url ip address to my duckdns name.

by the way , he “allowed networks” & “banned ips” have moved tho the auth provider section, I believe.

Thanks for you prompt replay but I have done that:

The bans are still in http but the allowed network has moved.

To the OP, Bosborne is right… you will need to use the duckdns address in the iFrame.

I have just done that, rebooted hassio, quitted and restarted chrome.
Now when I click on the Configurator in the side panel, it asks for the password, after entering the password set in the configurator config it returns ‘Policy not fulfilled’, if I enter in a wrong password it just keeps asking for the correct password.
If I tried to select InfluxDB, I get ‘Connecting’ in the bottom LH corner of the hassio screen for a while then the greyed out sad face icon on the page.

That’s an ssl error I think… in config, the ssl location is different to the addon config… I don’t use it like this… I use a Reverse Proxy and have ssl disabled in the addon config… try adding the /ssl/ to the path in the addon (and restart it)

What does your “auth_provider” config look like? I think Ihad that issue when using “trusted networks”.

Not sure what you mean there David

This one?

    "data": {
        "users": [
            {
                "password": "JDJiJDEyJDdPMHFUSVdjbzJzWFhtASp6OHBYU09SdHl1YTd5aWZRUWc5WUFPQXBDTlEza3ZZOVBwLzdl",
                "username": "denver"
            },
            {
                "password": "JDJiJDEyJFdQeTdwZmYvRGtWYkZoRWEuY2k5eNirQVVtLmQ0LlU1bUMuc01vQ0NhWWxjd20wdk1NZDVL",
                "username": "mqtt_denver"
            },
            {
                "password": "JDJiJDEyJEc0bzNRTVVMRkdDNmFxNjBVc2J5cmVPeTAvOLiufmJubWZqVzVNeW5GYS9CdUFRclJlY2Q2",
                "username": "jane"
            }
        ]
    },
    "key": "auth_provider.homeassistant",
    "version": 1
}

I meant something like this:

  # Authentication providers
  auth_providers:
  - type: homeassistant