Problems with Image files for Raspberry Pi?


ok perhaps ive had too much festive Christmas wine over the last week but I am new to Home Assistant and installing this via your image files for the Raspberry Pi. Basically I have downloaded the version for the Pi 4 and Pi 3 (both 32-bit and 64-bit) and the file downloads and extracts on my Mac. I then use BalenaEtcher to burn the IMG file to the SD card and it comes back stating the IMG file downloaded is corrupt. I tried downloading again and no luck at all. I then downloaded via my Windows Surface Pro and again if comes back with a file corruption error in BalenaEtcher. The IMG file was extracted and is showing as 2.147,483,648 in size. When downloading using my Mac the file automatically extracts to this size. For Windows I used 7Zip to extract and both are showing the same extracted file size.

Trust me I am not a numpty and I am used to burning IMG files to SD cards although I am currently sitting here thinking I must be!!

Are your versions I am trying to download are corrupt?

Don’t extract the files, just flash the archive.

OK still no luck.

Just redownloaded and tried your suggestion as the file is showing as ‘hassos_rpi4-3.7.img.gz’ and is 182,442,027 bytes in size. Note: On the Mac it automatically extracts to the larger IMG file size of 2.15 GB’s so I used my Windows Surface Pro. Burning hassos_rpi4-3.7.img.gz and comes back with File Corrupt in BalenaEtcher.

Maybe there is a issue with your broadband connection that is corrupting the files - I have seen this before. Can you download the files via another method and try that ?

I downloaded RPI4 and RPI4-64 some days ago, and now are installed and working.

Just did a test by downloading the pi4 32 bit image and flashed it to a spare card, no issues.

Use a different programme to flash the image. I assume MacOS has dd.

You shouldn’t use the compressed image, unzip it first.

Guess what! It was the bloody software used to burn the ISO. I’ve always used it no problem and installed a new version and problem solved. Cheers!!

I’m currently facing the same issue. I tried with both ElenaBatcher and dd on Mac. Batcher tell me flash was successful but Mac gives me an error that it can not detect the filesystem.

The sd card should end up with a fat partition and an ext4 partition.

After flash with dd or with Elena sd card looks like this

you are right, I downloaded an img.gz file and there are 8 partitions on it.

Any updates on this?

Same problem in version 3.11

After a while i wanted to start again with home-assistant. But it seems the error is still the same. After flashing with Etcher (latest version) the sd card looks the same with these 8 partitions. Anything i’m doing wrong? image is 4.16

Version 5.9, Mac OSX 10.15.17.

Tried with Balena Etcher and DD and my SD card looks like this for both 64bit and 32bit on for pi3:

Same boat as everyone else on here. Is there a solution?

I tried booting the pi off of the 'unreadable ’ 8GB SD card with the image and only got to the HA command prompt.

My pi came with a 32GB SD card with the OS system.

Am I to flash the HA image to that SD card or to a second SD card mounted on the USB bus?

I have same problem: download the image file and flash it to SD card using balenaEtcher renders the card unreadable. Tried the same thing using Raspberry Pi Imager and with same result. Getting frustrated. OS= BigSur 11.1

any pointers welcome!
Thanks in advance

1 Like

Hi did exactly the same.
Even bought a new SD card with 64GB

If I try to open img file, it says its corrupt…

I ve also tried the 32Bit file w/o success

When inserting the card into the Win PC, only one 32MB partition incl. hasso is shown.
In the computer administration there is only this 32MB partition

Same issue here. Anyone figure this out?