Problems with installation Z-wave

Hi All,

I try to install a Z-wave network but I get some errors and I wont be able to pair zwave devices.
I put an Aeotec Gen 5 Z-Wave stick in my RP3. After a while the z-wave network management area in Homeassistant is visible. I seems the installation went ok. However, when I try to pair a device by pressing add node a few errors occur. It is not a surprise that the pairing fails.

  File "/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zwave/__init__.py", line 358, in add_node
    network.controller.add_node()
  File "/srv/homeassistant/lib/python3.4/site-packages/openzwave/controller.py", line 657, in add_node
    return self._network.manager.addNode(self.home_id, doSecurity)
  File "src-lib/libopenzwave/libopenzwave.pyx", line 4244, in libopenzwave.PyManager.addNode (openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.cpp:31062)
TypeError: an integer is required
2017-09-09 15:50:58 WARNING (Thread-10) [openzwave] Can't lock controller for command : add_node

Also the OZW_Log show a lot off warnings:

2017-09-09 16:08:46.542 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.557 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.574 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.590 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.607 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.623 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.639 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.655 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.671 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.687 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.
2017-09-09 16:08:46.704 Warning, WARNING: Out of frame flow! (0x00).  Sending NAK.

I search a lot but I cant solve the problem on my own. Does anybody know a solution?

Thanks

Nick

PS i’m using the latest version of Hassbian 0.53.0

After a few hours I found out that I used a wrong usb path. My path is /dev/ttyACM* instead of /dev/ttyUSB* as described at https://home-assistant.io/docs/z-wave/#zwavenetwork_complete

This post can be closed!

If you use the device id you can avoid problems with /dev/ttyACM changing.

from the command line
ls /dev/serial/by-id and use the result in your configuration.yaml. The by-id won’t change.

4 Likes

@zarthan: Thanks for this! Your tip is saving me a ton of time rebooting/changing config files while I debug my Zwave network. Cheers!

1 Like

Happy it is working for you. Saves me a ton as well.

Something as simple as your comment helps others probably more then you may realise. Thanks!

1 Like

How do you input that on configuration.yaml
I did ls /dev/serial/by-id and got usb-0658_0200-if00
I have this on my Configuration.yaml
zwave:
usb_path: /dev/ttyACM0
device_config: !include zwave_device_config.yaml
and dit this after i first dit
ls -ltr /dev/tty*|tail -n 1
crw-rw---- 1 root dialout 166, 0 nov 5 22:26 /dev/ttyACM0

I had have an restart after power lost and apparently i think after reboot the port is changing.

Simply replace the
usb_path: /dev/ttyACM0
with
usb_path: /dev/serial/by-id/usb-0658_0200-if00

That won’t change through reboots.

Yes that works,
Thanks.

1 Like

Now i have Hassio, but here this won’t work, as i could not do anything from terminal (Apples Putty)

1 Like

You should be able to use the SAMBA addon and directly edit the configuration files. Use something like Notepad++ to do your editing.

yes but too bad looking for the exact usbport is not possible anymore:
i dit now again s /dev/serial/by-id
command not found.
And for the record, the usb-0658_0200-if00 a few messages before is from another Raspberry with Homebridge and that PI is not used now.
On my system i got hardware:

serial:
    /dev/ttyAMA0
    /dev/ttyACM0
input:
disk:
gpio:
    gpiochip0
    gpiochip128
    gpiochip100
audio:
    0:
        name: bcm2835_alsa - bcm2835 ALSA
        type: ALSA
        devices:
            [object Object]
            [object Object]

So which to use when installing Zwave? /dev/ttyAMA0 or …ACM0?

Tried it with ACM0 and that works.

Since aboud 1 march 2019 i got Hassio on Virtual Machine Manager Synology. Zwave aeotec stick 5th gen

I tried everything, /def/tty /def/ttyS1 /def/ttyS2 /def/ttyS3 /def/ttyS0 and always installed succes, but then go to settings integrations … this integration has no devices.
i also cannot reach the zwave configuration.
Tried also ls -1tr /dev/tty*|tail -n 1
/dev/tty no luck